mysql not starting with lampp - error log [Solved]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

mysql not starting with lampp - error log [Solved]

Postby tonyawards » 15. July 2011 05:09

I just did a reinstall of lampp as I had to perform a clean install of my computer and am reconfiguring everything. Lampp always worked here fine but now I cannot get mysql to start:

# /opt/lampp/lampp start
Starting XAMPP for Linux 1.7.4...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

I tried "# netstat -a | grep -e mysql -e 3306" but got no error conflict result.

I looked in /lampp/logs/error_log and I'll post it here since I'm pretty new to all this and am not sure how to interpret and fix my problem. The first configuration failed error alert is a bad start... - if that's what it is I don't really know how to debug it. Log here:

Code: Select all
[Sun Jul 10 18:46:55 2011] [alert] (EAI 5)No address associated with hostname: mod_unique_id: unable to find IPv4 address of "zenboy"
Configuration Failed
[Sun Jul 10 18:46:57 2011] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun Jul 10 18:46:57 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Jul 10 18:46:57 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Jul 10 18:46:57 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Jul 10 18:46:57 2011] [notice] Digest: done
[Sun Jul 10 18:46:58 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun Jul 10 18:46:58 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun Jul 10 18:46:58 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_ssl/2.2.17 OpenSSL/1.0.0c PHP/5.3.5 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Jul 10 18:59:58 2011] [error] [client 127.0.0.1] PHP Warning:  checkdate() expects parameter 1 to be long, string given in /opt/lampp/htdocs/xampp/biorhythm.php on line 105, referer: http://127.0.0.1/xampp/biorhythm.php
[Sun Jul 10 19:41:03 2011] [error] [client 127.0.0.1] File does not exist: /opt/lampp/htdocs/home
[Sun Jul 10 19:41:09 2011] [error] [client 127.0.0.1] File does not exist: /opt/lampp/htdocs/home
[Sun Jul 10 19:41:43 2011] [error] [client 127.0.0.1] File does not exist: /opt/lampp/htdocs/home
[Sun Jul 10 19:43:33 2011] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/public_html
[Sun Jul 10 20:03:16 2011] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/public_html
[Sun Jul 10 20:03:19 2011] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/public_html
[Sun Jul 10 20:03:21 2011] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /opt/lampp/htdocs/public_html
[Sun Jul 10 20:20:21 2011] [notice] caught SIGTERM, shutting down
[Wed Jul 13 20:30:03 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Jul 13 20:30:03 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Jul 13 20:30:03 2011] [notice] Digest: generating secret for digest authentication ...
[Wed Jul 13 20:30:03 2011] [notice] Digest: done
[Wed Jul 13 20:30:04 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Jul 13 20:30:04 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Jul 13 20:30:04 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_ssl/2.2.17 OpenSSL/1.0.0c PHP/5.3.5 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Wed Jul 13 20:35:23 2011] [error] [client 127.0.0.1] PHP Warning:  fopen(lang.tmp) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/lang.php on line 2, referer: http://127.0.0.1/xampp/splash.php
[Wed Jul 13 20:35:23 2011] [error] [client 127.0.0.1] PHP Warning:  fwrite() expects parameter 1 to be resource, boolean given in /opt/lampp/htdocs/xampp/lang.php on line 3, referer: http://127.0.0.1/xampp/splash.php
[Wed Jul 13 20:35:23 2011] [error] [client 127.0.0.1] PHP Warning:  fclose() expects parameter 1 to be resource, boolean given in /opt/lampp/htdocs/xampp/lang.php on line 4, referer: http://127.0.0.1/xampp/splash.php
[Wed Jul 13 20:37:43 2011] [notice] caught SIGTERM, shutting down
[Wed Jul 13 20:37:58 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Jul 13 20:37:58 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Jul 13 20:37:58 2011] [notice] Digest: generating secret for digest authentication ...
[Wed Jul 13 20:37:58 2011] [notice] Digest: done
[Wed Jul 13 20:37:59 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Jul 13 20:37:59 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Wed Jul 13 20:37:59 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_ssl/2.2.17 OpenSSL/1.0.0c PHP/5.3.5 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Wed Jul 13 21:02:52 2011] [notice] caught SIGTERM, shutting down
[Thu Jul 14 17:31:58 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Jul 14 17:31:58 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Thu Jul 14 17:31:58 2011] [notice] Digest: generating secret for digest authentication ...
[Thu Jul 14 17:31:58 2011] [notice] Digest: done
[Thu Jul 14 17:31:59 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Jul 14 17:31:59 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Thu Jul 14 17:31:59 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_ssl/2.2.17 OpenSSL/1.0.0c PHP/5.3.5 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Thu Jul 14 17:35:20 2011] [notice] caught SIGTERM, shutting down
[Thu Jul 14 20:19:46 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Jul 14 20:19:46 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Thu Jul 14 20:19:46 2011] [notice] Digest: generating secret for digest authentication ...
[Thu Jul 14 20:19:46 2011] [notice] Digest: done
[Thu Jul 14 20:19:47 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Jul 14 20:19:47 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Thu Jul 14 20:19:47 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_ssl/2.2.17 OpenSSL/1.0.0c PHP/5.3.5 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations


As you see, I tried restarting in the same way several times (what's that definition of insanity again... :) ) but no luck. I am also trying (no joy so far) to set it up with a symlink to a public_html directory in my /home. But getting mysql to work obviously has to come first and that's a topic for another post, anyway. BTW, I run lampp here without security (it's just me, offline) and that has not been a problem before.

Any ideas as to what's happening and how to fix it? My hostname for my box is not 'localhost' but a unique one, and the same as before when I did have it installed, so that shouldn't be the issue. (The only difference in my new installation is that it's set up with lvm instead of physical partitions - can that somehow be it?) I've searched the forum and googled but haven't found my situation yet. So I'm stumped.

Thanks everyone.
Last edited by tonyawards on 16. July 2011 21:04, edited 1 time in total.
tonyawards
 
Posts: 5
Joined: 17. May 2009 01:30

Re: mysql not starting with lampp - error log

Postby tonyawards » 16. July 2011 21:03

Well, it's fixed. Several threads here and elsewhere helped me piece it together. For someone who may have a similar situation, this is what I had to do.

I discovered from looking through my distro's forum (Sabayon) that kde's kwallet can cause all sorts of havoc. i had been having a simultaneous problem with it not allowing access to my network and had disabled it, so I reset kwallet and network manager and rebooted. They are now playing well together and, though I don't know how, I do feel this was part of my access issues. For what that's worth from a linux and php n00b...

I then gave full -R 777 permissions to /lampp (it's just me so I'm not worried about security) which gave me back mysql but did not then allow phpmyadmin to load. So I then changed the permissions for the /phpmyadmin directory as well as /phpmy admin/config.inc.php to 775 and that seemed to be sufficient. I am sure there is a more correct way to do this without compromising security, but I am not experienced enough in all this to know what configuration files to specifically work with.

Now the symlink that I was also trying to set up to my /home/public_html directory is working as well and I can see my index of sites at http://127.0.0.1/public_html/. Finally...

I hope this can help someone; it's not a perfect fix, I suppose, but it's working :) . I'll mark this as solved for now, but if anyone can shed some more light on a better way to set it all up I'd love to hear it. Thanks to Kai and everyone for an incredibly useful package - I certainly don't take it for granted :D .
tonyawards
 
Posts: 5
Joined: 17. May 2009 01:30


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests