Problem in installing xampp

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Problem in installing xampp

Postby floral » 02. June 2011 20:49

I tried to install xampp with two different ways and I have problem with both.

In the first one, I followed the steps shown here : http://www.apachefriends.org/en/xampp-linux.html#377
but when I type "su" in terminal and type in my password, i get the message "su: Authentication failure" , I stopped trying with this way.

In the second one, I followed the steps shown here : http://forum.ubuntu-gr.org/viewtopic.php?f=9&t=3400
Through Alt+F2, I extracted the files of xampp in the /opt , the directory for xampp is : /opt/lampp/htdocs/xampp
When I type localhost in firefox, I get this message :
It works!
This is the default web page for this server.
The web server software is running but no content has been added, yet.
,
however no page for configuration of xampp opened.
Also, the index.php file found in the htdocs directory says :
Code: Select all
<?php
   if (!empty($_SERVER['HTTPS']) && ('on' == $_SERVER['HTTPS'])) {
      $uri = 'https://';
   } else {
      $uri = 'http://';
   }
   $uri .= $_SERVER['HTTP_HOST'];
   header('Location: '.$uri.'/xampp/');
   exit;
?>
Something is wrong with the XAMPP installation :-(


I deleted the lamp file from /opt and tried it all over again. The same result.
Also, when I type /opt/lampp/htdocs/xampp start in terminal, i get a message that it did not find the directory :roll:
the directory is there!
Help!
I use linux 10.04.1

Another odd thing, is that when I tried to change the permission of the htdocs - as seen in the second guide - it does not let me change them.
floral
 
Posts: 1
Joined: 02. June 2011 20:29

Re: Problem in installing xampp

Postby tuxer » 02. September 2011 10:01

hi

Sure that /opt/lampp/htdocs/xampp start is the right command?
I think it is /opt/lampp/lampp start, isnt it?
tuxer
 
Posts: 5
Joined: 02. September 2011 09:07
Location: Germany

Re: Problem in installing xampp

Postby JonB » 03. September 2011 14:49

A. - you won't be able start apache without root access. If you are getting an 'su authentication failure' - it means you either don't have/possess a valid 'root' password or the context you are in does not allow that. So you need to fix that first.

B. - The other issues are a consequence of that problem. Including why you can't 'chown' the files.

C. - tuxer is right - its /opt/lampp/lampp start - BUT you can only do that in superuser mode.

Good Luck
8)


yr2sft
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
XAMPP Version: 1.8.3-2
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests