Trying to use symbolic links

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Trying to use symbolic links

Postby AntiLarsson » 17. May 2011 21:10

Hi
I'm trying to get Xampp to follow symbolic links in the htdocs. The problem is that I get a 403 Access forbidden! page instead of my site. I added a symbolic link in the htdocs pointing to the directory I want to access. The command used is "ln -s /path/to/dir new_link" the link is working when cd:d into. The permissions on the directory the link is pointing to is set to 777. I added
Code: Select all
<Directory /new_link>
    Options FollowSymLinks
    AllowOverride None
    #XAMPP
    #Order deny,allow
    #Deny from all
</Directory>
in /opt/etc/httpd.conf on line 243. The version I'm trying to use is XAMPP Linux 1.7.4.

Hopefully some one got a clue because I don't any more.
AntiLarsson
 
Posts: 2
Joined: 17. May 2011 20:52

Re: Trying to use symbolic links

Postby AntiLarsson » 17. May 2011 22:53

Got it working. There where some problems with the file permissions. I changed the permissions for the parent directory to /path/to/dir and everything works.
AntiLarsson
 
Posts: 2
Joined: 17. May 2011 20:52


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests