XAMPP doesn't work [added more and more info] [solved]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP doesn't work [added more and more info] [solved]

Postby cheperico » 28. April 2011 04:45

Hello!

First of all I must say that English is not my language but Spanish, so I am writing this query in Spanish and translated with Google translator.

I used XAMPP a bit in Windows, but in Debian I am a complete novice (novice to Debian, to VirtualBox and to XAMPP).

I installed Debian in a VirtualBox on Windows. All I did to try XAMPP, from downloading to attempt to run it, was done in Debian.

I think XAMPP is well installed (through the command indicated in the installation instructions) but when I run it I get 3 errors:

(NOTE: use Debian in Spanish, I get errors that are in Spanish and English translation is doing Google)

lampp: line 135: lampp: command not found
lampp: line 136: lampp: command not found
lampp: line 137: lampp: command not found


The command I use to run it is

bash lampp start

from

root@debian:/opt/lampp#

I do not know if the command is correct because, as I said, I nothing know about Debian.

If I type

lampp start

which is what the instructions say, I say

bash: lampp: command not found

The question is what do I have to do to use XAMPP.

Thanks!


EDIT #1
Tried XAMPP (LAMPP) in Mandriva (same circumstances: Windows -> VirtualBox -> Mandriva) . Same error. Error_log is empty.
Allways downloaded XAMPP 1.7.4 for Linux.

Please, help :(

Thanks!


EDIT #2
Another frustrating attempt to run XAMPP in Linux.

Environment:
1GB USB Flash Drive -> Slax

Booted my computer with that Linux distribution. Downloaded XAMPP 1.7.4 for Linux. Ran the installation command. Ran the starting command.

Same error (command not found). At least I have an error_log:

[Sun May 01 17:40:48 2011] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Sun May 01 17:40:48 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun May 01 17:40:48 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun May 01 17:40:48 2011] [notice] Digest: generating secret for digest authentication ...
[Sun May 01 17:40:48 2011] [notice] Digest: done
[Sun May 01 17:40:49 2011] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sun May 01 17:40:49 2011] [warn] RSA server certificate CommonName (CN) `localhost' does NOT match server name!?
[Sun May 01 17:40:49 2011] [notice] Apache/2.2.17 (Unix) DAV/2 mod_ssl/2.2.17 OpenSSL/1.0.0c mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations


Tried with other commands:

root@slax:/opt/lampp# sh lampp startapache
lampp: line 202: lampp: command not found
XAMPP: Starting Apache with SSL ...
root@slax:/opt/lampp# sh lampp startmysql
XAMPP: Starting MySQL...
root@slax:/opt/lampp# sh lampp php5
XAMPP: PHP 5.3.5 already active.
root@slax:/opt/lampp#


But localhost is still unable (under Firefox, http://localhost tries to download application/x-httpd-php)

Any idea?
cheperico
 
Posts: 2
Joined: 28. April 2011 04:19

Re: XAMPP doesn't work [added more and more info] [solved]

Postby cheperico » 05. May 2011 01:18

I still don't understand Linux, Apache and all that stuff, but I friend of mine did the job.
cheperico
 
Posts: 2
Joined: 28. April 2011 04:19


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests