help needed with xampp virtual hosts and file permissions

Problems with the Linux version of XAMPP, questions, comments, and anything related.

help needed with xampp virtual hosts and file permissions

Postby GordonK » 30. March 2011 19:20

Hi everyone, I'm new to this forum and it's only really out of necessity that I joined. I've been using XAMPP on windows with virtual hosts set up for the longest while. However, I've decided to make the switch over to Ubuntu 10.10 and I've been having the worst possible time setting up virtual hosts through XAMPP for the platform. Please keep in mind I'm rather new to Linux so please don't be upset if I'm missing something simple. Let me also say that I'm posting this topic as a last resort after searching for an answer on my own.

I'm almost sure I'm missing something simple but this is what's been happening: I've successfully installed XAMPP and can access http://localhost/xampp and http://localhost/phpmyadmin. I've gone through the set up of virtual hosts by removing the comment for the include statement in my httpd.conf file, followed by creating the virtual host in the httpd-vhosts.conf file and finally adding the address in my /etc/hosts file. After getting some permission problems, I read that I should change the permissions on the htdocs folder using chown to my own username and group (which I did). After which I changed the User and Group settings in my httpd.conf file to my own username and nogroup as the Group. After doing all this I couldn't access phpmyadmin as the file said it didn't have read permissions, so back to changing permissions to my own credentials. That worked and I'm now able to access everything however something is still wrong as I can't create any databases in phpmyadmin and I have no idea why.

I have a feeling my set up was far too complicated and I'm sure I did something incorrectly along the way but I'm at a loss as to what it is. Any help would be greatly appreciated.

I should also mention I'm trying to set virtual hosts for a folder outside of my htdocs folder, it's actually in folder called Work in my home/username/ folder.



Seems the issue lay within the fact that the sites I was trying to set virtual hosts for were copied from my windows development partition and as such did not have the appropriate file permissions as they normally would have if they were created in Linux itself. I'm posting this here just in case anyone may have similar troubles and reads this topic. Thanks to anyone who may have brainstormed the issue. Cheers.

P.S. Hopefully a mod can mark this topic as solved. Thanks.
Posts: 1
Joined: 29. March 2011 21:15

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests