Apache in XAMPP won't start, problem with libstdc++.so.6

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Apache in XAMPP won't start, problem with libstdc++.so.6

Postby moralez08 » 28. March 2011 08:16

Hye xampp, I'm new here.

I'm getting problem with XAMPP after my server down due to power trip.

Since then I cannot start apache from Xammp.

Starting XAMPP for Linux 1.7.2...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.


Here are apache error logs:

httpd: Syntax error on line 511 of /opt/lampp/etc/httpd.conf: Syntax error on line 5 of /opt/lampp/etc/extra/httpd-xampp.conf: Cannot load /opt/lampp/modules/libphp5.so into server: libstdc++.so.6: cannot handle TLS data

Base on the error i manage to find a solution http://www.mail-archive.com/debian-bugs ... 50160.html but sadly it cannot works.

My Linux version:
Linux internet-svr 2.6.9-100.ELsmp #1 SMP Fri Feb 18 01:47:46 EST 2011 i686 i686 i386 GNU/Linux

My env:

HOSTNAME=internet-svr
TERM=xterm
SHELL=/bin/bash
HISTSIZE=1000
USER=root
LS_COLORS=no=00:fi=00:di=00;34:ln=00;36:pi=40;33:so=00;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:ex=00;32:*.cmd=00;32:*.exe=00;32:*.com=00;32:*.btm=00;32:*.bat=00;32:*.sh=00;32:*.csh=00;32:*.tar=00;31:*.tgz=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.zip=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.bz=00;31:*.tz=00;31:*.rpm=00;31:*.cpio=00;31:*.jpg=00;35:*.gif=00;35:*.bmp=00;35:*.xbm=00;35:*.xpm=00;35:*.png=00;35:*.tif=00;35:
MAIL=/var/spool/mail/root
PATH=/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/root/bin
INPUTRC=/etc/inputrc
PWD=/root
LANG=en_US.UTF-8
SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass
SHLVL=1
HOME=/root
LOGNAME=root
LESSOPEN=|/usr/bin/lesspipe.sh %s
G_BROKEN_FILENAMES=1
_=/bin/env

Please help.

Thank you.
moralez08
 
Posts: 2
Joined: 28. March 2011 08:05

Re: Apache in XAMPP won't start, problem with libstdc++.so.6

Postby moralez08 » 06. April 2011 02:41

because of no reply, I setup new environment of Apache without using XAMPP...
moralez08
 
Posts: 2
Joined: 28. March 2011 08:05


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests