Problem with high loads on refresh

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Problem with high loads on refresh

Postby Dark_S7yle » 23. January 2011 01:14

Hello, i have this problem on XAMPP Linux 1.7.3a on linux slackware(64bit)13.0, when somebody refreshes the page the site , all of my servers are starting to lag alot. When somebody holds the f5 key the loads get extremely high, web and everything running with internet crashes.
I dont have alot of visitors the site is new, but with 9 online it lags alot.
Server machine Intel celeron 3.07ghz 3gig ram ddr2. Why is this happening?
Image
Dark_S7yle
 
Posts: 3
Joined: 23. January 2011 01:06

Re: Problem with high loads on refresh

Postby greno » 23. January 2011 02:05

XAMPP is mainly intended to be a development environment.

If you wish to use it for your production webserver then you need to take into account security and performance considerations.

I would suggest you start by making sure you've secured your installation.

Then google for "apache2 performance tuning". This will give you some articles that should help you properly tune Apache for best performance. Then use a benchmarking tool as you make changes to see their effects on your website performance.

Good luck.

Regards,
Gerry
greno
 
Posts: 54
Joined: 04. October 2006 19:25

Re: Problem with high loads on refresh

Postby Dark_S7yle » 23. January 2011 17:31

There is a reason this is happening "apache2 performance tuning" i readed it and found nothing to help me. Anyways thanks for your help.
Im going to ask again why it does high loads only on me?
Image
Dark_S7yle
 
Posts: 3
Joined: 23. January 2011 01:06

Re: Problem with high loads on refresh

Postby Sharley » 24. January 2011 01:11

This may an indication that you have been hacked through the webdav directory.

If so then all that should be in this directory are 2 files, index.html and webdav.txt.

If you have more than this then chances are your computer is a zombie.

Options:
Check your Apache access.log file for clues.

Change the webdav password or turn it Off in the etc/extra/httpd-dav.conf file if you are not using it.
(It may be turned On by default but the default user/pass is easy to find which is why it is being hacked)

Make sure in the httpd.conf file that this section is commented out and looks like this:
Code: Select all
# Distributed authoring and versioning (WebDAV)
#Include etc/extra/httpd-dav.conf


Change permissions to restrict total access.

Delete the webdav folder if you are not using it.

Add a report for your webdav issue to the already present WebDAV Exploit bug at:
http://bugs.xampp.org/view.php?id=170

This exploit is currently 'in the wild' especially infecting XAMPP for Windows:
viewtopic.php?f=16&t=43824
viewtopic.php?f=16&t=44140


If this does not apply then, sorry I don't have any more clues for you.

Good luck and best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Problem with high loads on refresh

Postby Dark_S7yle » 27. January 2011 17:17

etc/extra/httpd-dav.conf
I dont have that either the folder and the httpd-dav.conf file. Every visit is like a new process and its overloading the cpu.
Here - http://img191.imageshack.us/img191/6658/problemrs.png
The visit is opened in process "nobody" and its overloading the cpu
Image
Dark_S7yle
 
Posts: 3
Joined: 23. January 2011 01:06


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests