How-To: Add Ruby1.9 to XAMPP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

How-To: Add Ruby1.9 to XAMPP

Postby salsa_experience » 21. January 2011 17:38

hello dear staff - hello all


How-To: Add Ruby1.9 to XAMPP is this possible?"


Greetings
salsa_experience
 
Posts: 104
Joined: 25. August 2006 10:46

Re: How-To: Add Ruby1.9 to XAMPP

Postby greno » 22. January 2011 02:52

salsa_experience wrote:How-To: Add Ruby1.9 to XAMPP is this possible?"


Yes.

Read these How-To's:
How-To: Add Ruby-on-Rails to XAMPP
How-To: Add Ruby RVM, Rack and Passenger(mod_rails) to XAMPP

Ruby works perfectly in XAMPP. And so does Python and mod_wsgi. If you are interested there are other How-To's I created that also show how to add Python to XAMPP as well. They are also in the XAMPP for Linux forum.

Regards,
Gerry
greno
 
Posts: 54
Joined: 04. October 2006 19:25

Re: How-To: Add Ruby1.9 to XAMPP

Postby salsa_experience » 22. January 2011 09:57

Hello greno

many thanks for the quick answer.

greno wrote:
salsa_experience wrote:How-To: Add Ruby1.9 to XAMPP is this possible?"


Yes.

Read these How-To's:
How-To: Add Ruby-on-Rails to XAMPP
How-To: Add Ruby RVM, Rack and Passenger(mod_rails) to XAMPP

Ruby works perfectly in XAMPP. And so does Python and mod_wsgi. If you are interested there are other How-To's I created that also show how to add Python to XAMPP as well. They are also in the XAMPP for Linux forum.

Regards,
Gerry



great to hear: MY problem is the following: i run OpenSuse-Linux version 11.3. I am not able to install Ruby 1.9. Everytime i want to do that i end up with Ruby 1.8.7

I need to test some ruby-scripts. Therefore i need Ruby with the following gems

mechanize
nokogiri
utf8_utils


Is it possible to run XAMPP with Ruby 1.9 and all with all that extensions!?

Well i want to try out this!

best regards
salsa_e
salsa_experience
 
Posts: 104
Joined: 25. August 2006 10:46

Re: How-To: Add Ruby1.9 to XAMPP

Postby greno » 22. January 2011 22:26

Please follow the How-To's for Ruby.

It will install Ruby 1.9.2 into XAMPP - NOT into OpenSUSE.

And from there you can use Ruby 1.9.2 in XAMPP. And you can install whatever gems you like in Ruby environment inside XAMPP.


Regards,
Gerry
greno
 
Posts: 54
Joined: 04. October 2006 19:25


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests