Images aren't showing up [SOLVED]

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Images aren't showing up [SOLVED]

Postby cheese_whiz0 » 19. December 2010 20:43

My pages worked on xampp in windows so files are fine. Everything shows up on my linux installation except for images. However, the xampp test page comes out fine. The images show up as the alt text. Right clicking and viewing image info gets the right image path but viewing the image directly gives me 404. My xampp folder has 777 permissions. EnableMMAP and EnableSendfile are off and uncommented by default in my httpd.comf file.

errorlog excerpt:
[Sun Dec 19 11:29:42 2010] [error] [client ::1] File does not exist: /opt/lampp/htdocs/sexysexysex/images, referer: http://localhost/sexysexysex/index.php
[Sun Dec 19 11:29:42 2010] [error] [client ::1] File does not exist: /opt/lampp/htdocs/sexysexysex/images, referer: http://localhost/sexysexysex/index.php
[Sun Dec 19 11:29:42 2010] [error] [client ::1] File does not exist: /opt/lampp/htdocs/sexysexysex/images, referer: http://localhost/sexysexysex/index.php
[Sun Dec 19 11:29:42 2010] [error] [client ::1] File does not exist: /opt/lampp/htdocs/sexysexysex/images, referer: http://localhost/sexysexysex/index.php
[Sun Dec 19 11:29:42 2010] [error] [client ::1] File does not exist: /opt/lampp/htdocs/sexysexysex/images, referer: http://localhost/sexysexysex/default.css
[Sun Dec 19 11:29:48 2010] [error] [client ::1] File does not exist: /opt/lampp/htdocs/sexysexysex/images, referer: http://localhost/sexysexysex/index.php
[Sun Dec 19 11:33:27 2010] [error] [client ::1] File does not exist: /opt/lampp/htdocs/sexysexysex/images, referer: http://localhost/sexysexysex/index.php

The filepath is not complete for some reason. Instead of /opt/lampp/htdocs/sexysexysex/images/picture.jpg it cuts off. When I deleted "/" in my php file the error log shows /opt/lampp/htdocs/sexysexysex/imagespicture.jpg. So it's not seeing the subdirectory. However, my php includes can see and use the template files stored in the template subdirectory.

.

.

.

:|
Last edited by cheese_whiz0 on 21. December 2010 08:19, edited 1 time in total.
cheese_whiz0
 
Posts: 3
Joined: 19. December 2010 20:22

Re: Images aren't showing up

Postby Altrea » 19. December 2010 23:33

which owner and permissions does the images folder have?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Images aren't showing up

Postby cheese_whiz0 » 20. December 2010 17:50

ownership is under my acc name in the users group
everyone can view and modify content
cheese_whiz0
 
Posts: 3
Joined: 19. December 2010 20:22

Re: Images aren't showing up [SOLVED]

Postby cheese_whiz0 » 21. December 2010 08:21

Stupid problem is stupid. Apache is case sensitive on my linux box. My image folder was named 'Image'. Renamed to 'image'. Solved. Was not case sensitive on windows.
cheese_whiz0
 
Posts: 3
Joined: 19. December 2010 20:22


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests