2 upgrade questions

Problems with the Linux version of XAMPP, questions, comments, and anything related.

2 upgrade questions

Postby chrille156 » 27. November 2010 12:36

Hi. I have two questions about upgrading:

1.) If I upgrade xampp-for-linux - will my configuration/extensions/permissions stay the same? My installation is about two years old.

2.) Is it possible to update only apache or mysql without using an apachefriends-upgrade. Could be useful if there's an urgent securityfix.

Thank you!
chrille156
 
Posts: 3
Joined: 18. October 2010 11:30

Re: 2 upgrade questions

Postby JonB » 28. November 2010 17:02

Well - I think knowing the exact version you are currently on would maybe get you a few answers.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: 2 upgrade questions

Postby Altrea » 28. November 2010 17:23

chrille156 wrote:2.) Is it possible to update only apache or mysql without using an apachefriends-upgrade. Could be useful if there's an urgent securityfix.


This can be answered very very quick:
If you have to ask this question here, you aren't able to do this.
Maybe it's possible for someone who knows exactly how the XAMPP components are compiled, configured and harmonized to each other.
But that is not supported by the XAMPP developers.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: 2 upgrade questions

Postby chrille156 » 29. November 2010 23:05

Thank you for taking time.

JonB wrote:Well - I think knowing the exact version you are currently on would maybe get you a few answers.


Sorry about that.. I'm running 1.6.3 on 32-bit system.

Altrea wrote:
chrille156 wrote:2.) Is it possible to update only apache or mysql without using an apachefriends-upgrade. Could be useful if there's an urgent securityfix.


This can be answered very very quick:
If you have to ask this question here, you aren't able to do this.
Maybe it's possible for someone who knows exactly how the XAMPP components are compiled, configured and harmonized to each other.
But that is not supported by the XAMPP developers.


That is the documentation I was looking for.. But it guess this isn't a huge problem since Apache has a quite flawless history.. Am I right?
chrille156
 
Posts: 3
Joined: 18. October 2010 11:30

Re: 2 upgrade questions

Postby JonB » 30. November 2010 02:29

Apache is fairly stable, and, unlike PHP, does not a have a new release that is radically different for each phase of the moon (just kidding a bit). Still - due to PHP's dependence on the Apache server, the two DO need to be compiled in the same manner.

MySQL likely could be upgraded, but again - as Altrea pointed out - if one has to ask, the likelihood is that they can't accomplish the task. It would be an uncomfortable experience even for a knowledgeable user.

In any event - going off on such excursions makes it virtually impossible to get meaningful help, since NO ONE will have a system like yours (no way to test). Its actaully better to install the full stack that comes with your particular distribution, there are built-in mechanisms for maintaining those stacks (worth knowing about).

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests