got a packet bigger (solved)

Problems with the Linux version of XAMPP, questions, comments, and anything related.

got a packet bigger (solved)

Postby benos » 18. November 2010 20:36

if you get "got a packet bigger than max allowed packet bytes"

go to my.cnf under 777 permision

change both max_allowed_packet fields to the same value (in both put the same value - better be 64m).

than save the file.

if it's still don't work, try to rechange it's permission to 644, it worked for me than...
Last edited by benos on 19. November 2010 18:50, edited 1 time in total.
benos
 
Posts: 4
Joined: 18. November 2010 19:40

Re: i don't want to giveup xampp !, but i have a problem :\

Postby JonB » 19. November 2010 03:34

why don't you use the mysql.exe (on Linux mysql) CLI ?? :idea:

(that's the MySQL monitor aka MySQL CLI - Command Line Interface - its a raw SQL interface)

http://www.techiecorner.com/31/how-to-r ... dump-file/

read down to about the middle of the page

he/she explains about large file direct imports.

and

http://www.webcheatsheet.com/SQL/mysql_ ... hp#restore

Note - you may need to create the database and/or users first, and sometimes 'tip article' authors are a bit off on the parameter syntax. sometimes you need --user instaed of -u and --password instead of -p. The need to create the user is very likely, the need to create the database depends on the options used dumping/exporting (the matter of create/drop inclusions)

Its worth learning, as you will avoid all this timeout crap when you are working on your own servers. phpMyAdmin is a great tool, but that's what it is - a tool -. Its not a replacement for knowledge :shock:


8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests