cgi only works for pl extension

Problems with the Linux version of XAMPP, questions, comments, and anything related.

cgi only works for pl extension

Postby Bigbread » 08. November 2010 16:20

A quick test of a "test.cgi" script threw up the "Premature end of script headers" error.

I renamed the script to "test.pl" and it worked fine.

httpd.conf has the line: AddHandler cgi-script .cgi .pl

so why is the .cgi extension failing?
Bigbread
 
Posts: 17
Joined: 12. May 2007 12:05

Re: cgi only works for pl extension

Postby Bigbread » 08. November 2010 16:43

Got the .cgi extension working - had to specifically allow it in .htaccess

Options +ExecCGI

so now I'm wondering why the .pl extension bypassed this restriction
Bigbread
 
Posts: 17
Joined: 12. May 2007 12:05

Re: cgi only works for pl extension

Postby Bigbread » 08. November 2010 17:05

That directive shouldn't have been necessary because the default includes it for all directories:

Options Indexes FollowSymLinks ExecCGI Includes

I just reversed everything I did previously but now .cgi and .pl are working.

The problem was caused by some of the test files having been created under Windows. Doh.
Bigbread
 
Posts: 17
Joined: 12. May 2007 12:05


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 1 guest