error on installing xammp for x86-64

Problems with the Linux version of XAMPP, questions, comments, and anything related.

error on installing xammp for x86-64

Postby abdolah » 09. October 2010 07:23

i found this to install xampp on fc13:

I was installing XAMPP on Fedora 11 64-bit today, and I saw this famous message:

sudo /opt/lampp/lampp startapache
XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system.

The message is very clear that XAMPP doesn’t like 32-bit system. So, we will need to cheat XAMPP that the system is 32-bit. First, we will need to install some libraries:

sudo yum -y install glibc.i686 libgcc.i686 libstdc++.i686

and now, we need to skip the 32-bit annoying check:

sudo nano /opt/lampp/lampp

Replace the following from:

# XAMPP is currently 32 bit only
case `uname -m` in
*_64)
if /opt/lampp/bin/php -v > /dev/null 2>&1
then
:
else
$de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
$de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
exit
fi
;;
esac

To:

# XAMPP is currently 32 bit only
#case `uname -m` in
# *_64)
# if /opt/lampp/bin/php -v > /dev/null 2>&1
# then
# :
# else
# $de && echo "XAMPP gibt es zur Zeit nur als 32-Bit Applikation. Bitte verwende eine 32-Bit Kompatibilitaetsbibliothek fuer Dein System."
# $de || echo "XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system."
# exit
# fi
# ;;
#esac

Now run the following the start XAMPP:

sudo /opt/lampp/lampp startapache

Wow! Everything is working great!


but i have an error with it"

[sajad@sajad ~]$ su
Password:
[root@sajad sajad]# sudo /opt/lampp/lampp startapache

XAMPP is currently only availably as 32 bit application. Please use a 32 bit compatibility library for your system.
[root@sajad sajad]#
[root@sajad sajad]# sudo yum -y install glibc.i686 libgcc.i686 libstdc++.i686
Loaded plugins: presto, refresh-packagekit
Zend | 951 B 00:00
Zend_noarch | 951 B 00:00
adobe-linux-i386 | 951 B 00:00
atrpms | 3.0 kB 00:00
flash | 2.6 kB 00:00
rpmfusion-nonfree-updates | 2.8 kB 00:00
Setting up Install Process
Package glibc-2.12-1.i686 already installed and latest version
Package libgcc-4.4.4-2.fc13.i686 already installed and latest version
Package libstdc++-4.4.4-2.fc13.i686 already installed and latest version
Nothing to do
[root@sajad sajad]# sudo nano /opt/lampp/lampp
nano: symbol lookup error: /lib64/libncursesw.so.5: undefined symbol: _nc_set_no_padding
[root@sajad sajad]# sudo nano /opt/lampp/lampp
nano: symbol lookup error: /lib64/libncursesw.so.5: undefined symbol: _nc_set_no_padding
[root@sajad sajad]#


how i can solve it???
abdolah
 
Posts: 2
Joined: 09. October 2010 07:06

Re: error on installing xammp for x86-64

Postby abdolah » 09. October 2010 15:15

i solved it by continuing and ignoring the error.
abdolah
 
Posts: 2
Joined: 09. October 2010 07:06


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests