Update

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Update

Postby moissinac » 22. September 2010 16:58

I have updated my XAMPP on Ubuntu for 1.7.3a version
Apache doesn't start with the message
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/

To understand, I've read the item 'What's the secret about "Error 1"? in the XAMPP doc, which suggest to use
tail -2 /opt/lampp/logs/error_log

So, I can see the log:
[Wed Sep 22 17:54:29 2010] [notice] caught SIGTERM, shutting down
httpd: Syntax error on line 80 of /opt/lampp/etc/httpd.conf: Cannot load /opt/lampp/modules/mod_include.so into server: /opt/lampp/modules/mod_include.so: undefined symbol: ap_escape_html2

Apache starts, if I comment out the line
LoadModule include_module modules/mod_include.so
in httpd.conf

But, then I got some errors in some sites.
The first is
http://127.0.0.1/xampp/
which only displays
Notice: Undefined variable: PHP_SELF in /opt/lampp/htdocs/xampp/lang/fr.php on line 178

Some help is welcome
moissinac
 
Posts: 3
Joined: 08. June 2009 10:29

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests