[solv.]Can't run MySQL after reinstallation - access rights?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

[solv.]Can't run MySQL after reinstallation - access rights?

Postby lampak » 23. August 2010 20:49

Hi, I hope somebody here can help me because it really drives me mad.

I had xampp once and I removed it, following this elaborate manual.

Now I've downloaded and reinstalled xampp. But this time MySQL won't work.

sudo ./lampp startmysql
Code: Select all
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!

The *.err log:
Code: Select all
100823 21:36:59 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
100823 21:36:59 [Note] Plugin 'FEDERATED' is disabled.
/opt/lampp/sbin/mysqld: Can't find file: './mysql/plugin.frm' (errno: 13)
100823 21:36:59 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
100823 21:36:59  InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name /opt/lampp/var/mysql/ibdata1
InnoDB: File operation call: 'open'.
InnoDB: Cannot continue operation.
100823 21:36:59 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/laptop.pid ended

Anybody knows what's the problem?
I run Ubuntu and I'm a noob in any server-related matters.
Last edited by lampak on 24. August 2010 20:29, edited 1 time in total.
Posts: 2
Joined: 23. August 2010 20:28

Re: Can't run MySQL after reinstallation - access rights?

Postby glitzi85 » 24. August 2010 18:30

Could you please post the output of the following command:
Code: Select all
ls -la /opt/lampp/var/mysql

I assume that you installed XAMPP exactly as described here: http://www.apachefriends.org/en/xampp-linux.html#377

User avatar
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Can't run MySQL after reinstallation - access rights?

Postby lampak » 24. August 2010 20:20

More less. The only difference was that I extracted the package right-clicking it. But I copied it in the terminal to the same folder so it shouldn't make much difference.

What's more important is that I've figured out something's wrong with the 1.7.1 version and all the newer ones. I downloaded 1.6.8a version and MySQL worked. Upgraded to 1.7.0 - still worked. Upgraded to 1.7.1 - stopped working.

Any ideas?

edit: the log will be in a moment

edit2: seems the way of unpacking did make a difference. I've reinstalled the latest version with that command and now everything seems to be fine :D Thank you very much :)
Posts: 2
Joined: 23. August 2010 20:28

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests