install PS PECL at Linux (Ubuntu)

Problems with the Linux version of XAMPP, questions, comments, and anything related.

install PS PECL at Linux (Ubuntu)

Postby hiddenpearls » 11. August 2010 22:28

hey,

I have isntalled Ubuntu 10.04 and installed Xampp .. I need to install the PS extension now.
http://pecl.php.net/package/ps

I considered this post
viewtopic.php?p=157915
but pecl install ps doesn't work ..
please guide me the process.
hiddenpearls
 
Posts: 7
Joined: 11. August 2010 22:17

Re: install PS PECL at Linux (Ubuntu)

Postby hiddenpearls » 11. August 2010 22:36

Error I got is

No release available for "pear.php.net/ps"
install failed.
hiddenpearls
 
Posts: 7
Joined: 11. August 2010 22:17

Re: install PS PECL at Linux (Ubuntu)

Postby lderdziuk » 12. August 2010 03:53

Hi,

I've tried to install ps on my configuration, this is what I got:

Code: Select all
*:/opt/lampp/bin$ sudo ./pecl install ps
downloading ps-1.3.6.tgz ...
Starting to download ps-1.3.6.tgz (635,832 bytes)
................................................................................................................................done: 635,832 bytes
5 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626


and then it started to configure ps (without success cause I don't have needed dependencies).

Which version of xampp / php / zend are you using?
lderdziuk
 
Posts: 3
Joined: 15. March 2010 12:39

Re: install PS PECL at Linux (Ubuntu)

Postby hiddenpearls » 12. August 2010 08:21

actually, problem on my ubuntu is ..
I dont have access to internet there .

I can copy the files of PS to any folder ..
hiddenpearls
 
Posts: 7
Joined: 11. August 2010 22:17

Re: install PS PECL at Linux (Ubuntu)

Postby hiddenpearls » 12. August 2010 08:23

I have latest xampp version from their website
hiddenpearls
 
Posts: 7
Joined: 11. August 2010 22:17

Re: install PS PECL at Linux (Ubuntu)

Postby hiddenpearls » 12. August 2010 14:28

lderdziuk wrote:Hi,

I've tried to install ps on my configuration, this is what I got:

Code: Select all
*:/opt/lampp/bin$ sudo ./pecl install ps
downloading ps-1.3.6.tgz ...
Starting to download ps-1.3.6.tgz (635,832 bytes)
................................................................................................................................done: 635,832 bytes
5 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626


and then it started to configure ps (without success cause I don't have needed dependencies).


I got the same thing as u got above .. but I got AUTOCONFIG error and PHPIZE .. what it is ?
how to get rid of it ?
hiddenpearls
 
Posts: 7
Joined: 11. August 2010 22:17

Re: install PS PECL at Linux (Ubuntu)

Postby hiddenpearls » 13. August 2010 10:31

Anyone please help me to resolve this issue ..
hiddenpearls
 
Posts: 7
Joined: 11. August 2010 22:17

Re: install PS PECL at Linux (Ubuntu)

Postby lderdziuk » 17. August 2010 08:41

Sorry for delay, I'm in China now and don't have much time to check this forum.

I'd guess that you have some dependencies problem.

Do you have any other instalation of php/apache?


Do you have 'phpize' tool? If you do, try to do the following:
Code: Select all
$
 cd extname (your ps directory)
$ phpize
$ ./configure
$ make
# make install


The output of pecl install command would be nice. If you don't have internet on the other computer, you can create a log file and paste it here:
Code: Select all
pecl install ps > pinstal.log
lderdziuk
 
Posts: 3
Joined: 15. March 2010 12:39


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 8 guests