Installing different PHP version

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Installing different PHP version

Postby mlatelcom » 01. August 2010 21:49

Hello,
I want to install Xampp with a different version of php. The reason is because joomla has many issues with 5.3.x versions since it doesn't completely support it yet.
Anyone know how to do it?
mlatelcom
 
Posts: 2
Joined: 01. August 2010 21:38

Re: Installing different PHP version

Postby Altrea » 01. August 2010 22:02

The only component of Joomla which is not yet compatible with PHP 5.3 is OpenID.
All other components should run very well with this PHP version.

And last but not least: XAMPP is a package of several components and just supported as it is (a package).
If you want to upgrade/downgrade one single component, you had to do this on your own.

btw: If you really really want to use PHP 5.2.x, then you can use one of the previour XAMPP releases (recommend XAMPP 1.7.1 with PHP 5.2.9), which can be downloaded at sourceforge
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Installing different PHP version

Postby mlatelcom » 01. August 2010 22:14

thanks for the fast reply
actually I installed version 1.7.1 because of php version but i got another problem now browsing phpmyadmin
Undefined variable: PHP_SELF in /opt/lampp/htdocs/xampp/lang/en.php on line 166
I installed the last version first and I was able to install joomla; but later on I had some issues installing components and modules. So I tried everything I found on different forums...changing php.ini lines and some more things. I'm running my own testing server in fedora core 13 for development purposes; but I have also a website hosted at hostgator which is running ok, I just check at the hosting server versions and I realized the php version is lower:

Apache:
2.2.15
MySQL
5.1.47
phpMyAdmin
3.2.4
Perl:
5.8.8
PHP:
5.2.4

I was wondering if I just install the same versions they have could fix those issues I'm having.
mlatelcom
 
Posts: 2
Joined: 01. August 2010 21:38

Re: Installing different PHP version

Postby ragortue » 01. July 2015 19:55

Sorry to bump this up guys but which Php versions are still compatible with this?
Centos 5.6 Image
ragortue
 
Posts: 10
Joined: 09. March 2015 16:21
Operating System: Centos 5.6


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests