Error 126! Couldn't start Apache!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error 126! Couldn't start Apache!

Postby pmcmurrough » 19. July 2010 16:53

Hi,

I am trying to install Xampp but it will not start. I am getting the following error.

NSLU2:/home/paul/downloads# /opt/lampp/lampp start
Starting XAMPP for Linux 1.7.3a...
/opt/lampp/share/lampp/phpstatus: line 4: /opt/lampp/bin/php: cannot execute binary file
XAMPP: Starting Apache with SSL ...
/opt/lampp/bin/apachectl: line 100: /opt/lampp/bin/httpd: cannot execute binary file
XAMPP: Error 126! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
/opt/lampp/bin/mysql.server: line 260: /opt/lampp/bin/my_print_defaults: cannot execute binary file
/opt/lampp/bin/mysql.server: line 263: /opt/lampp/bin/my_print_defaults: cannot execute binary file
XAMPP: Couldn't start MySQL!
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.

Anyone any ideas?

Thanks,

Paul
pmcmurrough
 
Posts: 3
Joined: 19. July 2010 16:51

Re: Error 126! Couldn't start Apache!

Postby Nobbie » 21. July 2010 11:42

As I "accidently" can see, you are prompted with "NSLU2" (you really really really MUST PROVIDE this information at first).

That means, you are NOT running a standard PC, but a Linksys NSLU2, which is not compatible to standard Linux distributions. Obviously you have installed a special linux distribution for NSLU2 (there are a few versions out there), but Xampp is not compatible to that linux distributions.

You simply cannot run Xampp on your Linksys NSLU2. Instead you should install the Apache/PHP/MySQL Package which comes with your special linux distribution.
Nobbie
 
Posts: 7034
Joined: 09. March 2008 13:04

Re: Error 126! Couldn't start Apache!

Postby pmcmurrough » 21. July 2010 21:24

That explains things then. Thank you for the reply.
pmcmurrough
 
Posts: 3
Joined: 19. July 2010 16:51

Re: Error 126! Couldn't start Apache!

Postby princealway » 07. August 2010 12:56

This means you are not using a standard PC, but a Linksys NSLU2, which is not compatible with standard Linux distributions. Obviously you have installed a Linux distribution special for NSLU2 (there are some versions out there), but Xampp is not compatible with Linux distributions.
Life is either a daring adventure or nothing.
princealway
 
Posts: 4
Joined: 07. August 2010 12:45


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests