Help running Octave with PHP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Help running Octave with PHP

Postby Kne » 24. June 2010 21:15

Hi,
I installed Xampp for my Fedora 12 Linux for running PHP files. I am trying to call octave through PHP and it did not work. On trying with
system('/usr/bin/octave myfile.m 2>&1'), i get the following error message

/usr/bin/octave: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.0.0' not found (required by /usr/local/lib/octave-3.2.4/liboctinterp.so)
/usr/bin/octave: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.0.0' not found (required by /usr/local/lib/octave-3.2.4/liboctave.so)
/usr/bin/octave: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.0.0' not found (required by /usr/local/lib/octave-3.2.4/libcruft.so)
/usr/bin/octave: /opt/lampp/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libstdc++.so.6)

The Gcc version of my Linux is 4.4.3 but this seems to be a problem with Xampp. Is there a way to link my root gcc version with xampp or is there any other way to run octave through PHP?

Thanks in advance,
Elan.
Kne
 
Posts: 1
Joined: 24. June 2010 21:00

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests