Page 1 of 1

Configuring SSL Support

PostPosted: 09. June 2010 16:47
by shawnsmiley
I'm kind of amazed there isn't at least one topic on the forums on this. :-)

I'm trying to load up an existing site in my xampp environment to do some updates to it. Unfortunately the site uses SSL for every page and all of the links on the site are hard coded with the full domain names (i.e. https://domainname/pagename) so I can't easily disable SSL on the site to do the updates.

I have enabled ssl support using the /opt/lampp/lampp startssl and I've setup my vhosts file to point port 443 at my local copy of the site.

However when I try to access the site via SSL I receive the following error in Firefox(I've masked out the site URL):
Code: Select all
An error occurred during a connection to ************. 
SSL received a record that exceeded the maximum permissible length.
(Error code: ssl_error_rx_record_too_long)

Chrome gives the error:
Code: Select all
Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error

Are there any other steps to setting up SSL on XAMPP? So far I haven't been able to find anything either here or via Google searches on this for XAMPP.

I'm using XAMPP for Linux version 1.7.1 on Ubuntu 10.04 if that makes any difference.


Re: Configuring SSL Support

PostPosted: 09. June 2010 17:01
by shawnsmiley
Why is it you always figure out your problem right after posting a message to a forum? :-)

In case someone else has this problem, here are the steps I took to resolve it:
1. Create a SSL Certificate
Code: Select all
sudo /usr/sbin/make-ssl-cert /usr/share/ssl-cert/ssleay.cnf /opt/lampp/etc/ssl.crt/apache.pem

2. Update my vhosts config file at /opt/lampp/etc/extra/httpd-vhosts.conf
Code: Select all
<VirtualHost *:443>
    SSLEngine on
    SSLCertificateFile /opt/lampp/etc/ssl.crt/apache.pem

NOTE: I've only included the additional settings above, you sill need the server name and document root entries.

Restart Apache.

Re: Configuring SSL Support

PostPosted: 06. June 2011 14:23
by toreachdeepak

make-ssl-cert on my linux....

sudo /usr/sbin/make-ssl-cert /usr/share/ssl-cert/ssleay.cnf /opt/lampp/etc/ssl.crt/apache.pem


Deepak Bhatia