ERROR 1045 (28000): Access denied for user 'root'@'localhost

Problems with the Linux version of XAMPP, questions, comments, and anything related.

ERROR 1045 (28000): Access denied for user 'root'@'localhost

Postby rdp870 » 09. June 2010 15:14

Hi, I'm a super newbie at XAMPP. I was trying to create a database and username for my wordpress installation via phpmyadmin. Now, since I've created the database with password, I can't access MySQL through phpmyadmin. I've looked through php config files and put the appropriate user and passwords (or so I thought), but cannot get it to work. Any help would be appreciated.
rdp870
 
Posts: 1
Joined: 09. June 2010 15:09

Re: ERROR 1045 (28000): Access denied for user 'root'@'localhost

Postby Radzio » 09. June 2010 15:48

If you want to use phpmyadmin, you should change authorization method to cookie or http in phpmyadmin settings:
path/to/phpmyadmin/config.inc.php: (example line)
Code: Select all
$cfg['Servers'][$i]['auth_type']            = 'cookie'; /* Authentication method (config, http or cookie based) */
Radzio
 
Posts: 81
Joined: 05. June 2010 12:26


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests