Xammp not running

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Xammp not running

Postby shafishstix » 22. May 2010 09:24

Hi ive tried installing and running xampp on ubuntu linux and have came up with some problems. After downloading it and extracting it to /opt/lampp and trying the command "start lampp" all it comes up with is this - "start: Unknown job: lampp" in the terminal window. I'm a beginner in linux so i have no idea where to go from here. Thanks.
shafishstix
 
Posts: 2
Joined: 22. May 2010 09:18

Re: Xammp not running

Postby Nobbie » 22. May 2010 09:48

shafishstix wrote: trying the command "start lampp" all it comes up with is this - "start: Unknown job: lampp" in the terminal window. I'm a beginner in linux so i have no idea where to go from here


As a beginner, you should read docu by far more carefully. The commend you triggered is wrong and not mentioned in the docu. It is not "start lampp" but "/opt/lampp/lampp start" or (if you are not logged in as "root") "sudo /opt/lampp/lampp start".
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: Xammp not running

Postby shafishstix » 23. May 2010 08:05

Thanks for that, i actually was in the directory of /opt/lampp on my first attempt. Using the full path name + lampp start worked. Cheers.
shafishstix
 
Posts: 2
Joined: 22. May 2010 09:18

Re: Xammp not running

Postby Nobbie » 25. May 2010 09:50

shafishstix wrote:Thanks for that, i actually was in the directory of /opt/lampp on my first attempt.


But you stll entered the wrong commands (you switched the words). You entered "start lampp" instead of "lampp start". And, additionally, that would not work, as "." is not within the search PATH, therefore you have to enter "./lampp start" anyway.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests