Page 1 of 2

Transfer chmodded folders

PostPosted: 21. January 2004 21:42
by Repute
I want te transfer al my existing folders to an new linux server. But want to keep all the chmod settings of the folders what is the best way to do that? (The servers are in my private LAN)

How does the new backup system in LAMPP work?



PostPosted: 22. January 2004 09:28
by Oswald
Dear Repute! :)

It's very simple:

Step 1

Create the backup by calling

/opt/lampp/lampp backup
/opt/lampp/lampp backup secret

Where secret is your MySQL root password.

This command will create the following output:

Code: Select all
# /opt/lampp/lampp backup
Backing up databases...
Backing up configuration, log and htdocs files...
Calculating checksums...
Building final backup file...
Backup finished.
Take care of /opt/lampp/backup/

Step 2

The file /opt/lampp/backup/ contains your backuped data. Get this file to your new machine.

Step 3

On the new machine you need the same version of XAMPP as on your original/source machine.

Call (as root): sh

You shoud see something like this:

Code: Select all
# sh
Checking integrity of files...
Restoring configuration, log and htdocs files...
Checking versions...
Installed:   XAMPP 1.4.2
Backup from: XAMPP 1.4.2
Restoring MySQL databases...
Restoring MySQL user databases...
Backup complete. Have fun!
You may need to restart XAMPP to complete the restore.

That's all. As you can read you may need to restart XAMPP.

It should work perfectly (I tested it many times) but remember it's a beta feature.

Best regards


PostPosted: 22. January 2004 11:49
by Repute
Great wow this peace of software Rules!!! It so simpel...

Your defenitly the best!

Thanks for all your great work!!!



Cant acces database by backup

PostPosted: 26. January 2004 15:03
by Repute
Hhhmm everytime i try to backup with /opt/lampp/lampp backup or /opt/lampp/lampp backup secret
it says:

Can't acces database is Mysql running? etc.

I tried with and without pasword an with MySQL rinnung en not running...



PostPosted: 26. January 2004 15:05
by Oswald
Dear Repute!

Please call:

/opt/lampp/bin/mysql -uroot -p<yourpassword>

What do you get on your screen?


PostPosted: 26. January 2004 15:13
by Repute
bash: syntax error near unexpected token `newline'

PostPosted: 26. January 2004 15:15
by Oswald

Please call only


What do you see now?

PostPosted: 26. January 2004 15:18
by Repute
ERROR: 1045 Acces denied for user: root@localhost (using password: NO)

PostPosted: 26. January 2004 15:23
by Oswald
Okay. Please add now the options to the command:

-uroot -p<your password>

Please replace <your password> with your password. For example: -psecret

And again. What do you get? ;)

PostPosted: 26. January 2004 15:24
by Repute
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 10 to server version: 4.0.17-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

PostPosted: 26. January 2004 15:27
by Oswald
Great. If you still see the mysql> prompt please type quit.

Now call

/opt/lampp/lampp backup secret

Where you have to replace "secret" with your password.

And again, again: what do you see? ;)

PostPosted: 26. January 2004 15:33
by Repute
:? Can't access database. Is MySQL running? Added the MySQL root password to end of command line?

PostPosted: 26. January 2004 15:37
by Oswald
Okay... step by step...

Next try. Please call:

echo "show databases" | /opt/lampp/bin/mysql -uroot -ppassword

PostPosted: 26. January 2004 15:39
by Repute
Now it shows all the databases in a row

PostPosted: 26. January 2004 15:46
by Oswald
That's very, very strange.

Ok. Now could you please edit /opt/lampp/share/lampp/backup?

At line 27 you find:

d=`echo "show databases" | /opt/lampp/bin/mysql -uroot $passwd 2>/dev/null`

Please remove the 2>/dev/null. It should look like:

d=`echo "show databases" | /opt/lampp/bin/mysql -uroot $passwd`

Save and call again:

/opt/lampp/lampp backup secret

What is happening?