Version Incompatible I think?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Version Incompatible I think?

Postby concreteboots » 26. April 2010 13:21

When I start the httpd server I see this on the screen.

service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [ OK ]

My error logs say:-
[Mon Apr 26 13:03:51 2010] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Mon Apr 26 13:03:51 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Apr 26 13:03:51 2010] [notice] Digest: generating secret for digest authentication ...
[Mon Apr 26 13:03:51 2010] [notice] Digest: done
[Mon Apr 26 13:03:51 2010] [error] python_init: Python version mismatch, expected '2.6', found '2.6.2'.
[Mon Apr 26 13:03:51 2010] [error] python_init: Python executable found '/usr/bin/python'.
[Mon Apr 26 13:03:51 2010] [error] python_init: Python path being used '/usr/lib/python26.zip:/usr/lib/python2.6/:/usr/lib/python2.6/plat-linux2:/usr/lib/python2.6/lib-tk:/usr/lib/python2.6/lib-old:/usr/lib/python2.6/lib-dynload'.
[Mon Apr 26 13:03:51 2010] [notice] mod_python: Creating 4 session mutexes based on 256 max processes and 0 max threads.
[Mon Apr 26 13:03:51 2010] [notice] mod_python: using mutex_directory /tmp
[Mon Apr 26 13:03:52 2010] [notice] Apache/2.2.14 (Unix) DAV/2 PHP/5.3.2 mod_python/3.3.1 Python/2.6.2 mod_ssl/2.2.14 OpenSSL/1.0.0-fips-beta4 mod_perl/2.0.4 Perl/v5.10.0 configured -- resuming normal operations

If I use the httpd server for HTML all is fine, but when I use it for php, there is a problem.

[Mon Apr 26 13:07:33 2010] [error] [client 127.0.0.1] PHP Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0
[Mon Apr 26 13:07:33 2010] [error] [client 127.0.0.1] PHP Fatal error: Unknown: Failed opening required '/var/www/html/install.php' (include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0
[Mon Apr 26 13:07:35 2010] [error] [client 127.0.0.1] PHP Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0
[Mon Apr 26 13:07:35 2010] [error] [client 127.0.0.1] PHP Fatal error: Unknown: Failed opening required '/var/www/html/install.php' (include_path='.:/usr/share/pear:/usr/share/php') in Unknown on line 0

I'm using the latest version of Fedora 12, with all the latests updates that are available through YUM.

Can anyone advise me how to resolve the issue?
concreteboots
 
Posts: 2
Joined: 13. February 2010 14:26

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests