Unable to start phpMyAdmin

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Unable to start phpMyAdmin

Postby tuxwithoutpants » 23. April 2010 00:33

Hi all,

I'm using the distro PCLinuxOS 2010 (KDE), and installed XAMPP 1.7.3a. I can't seem to get phpMyAdmin running, every time I try I get:

phpMyAdmin - Error
Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

Both distro and xampp are fresh installations. Help?
Posts: 2
Joined: 23. April 2010 00:27

Re: Unable to start phpMyAdmin

Postby TravisBickle » 26. April 2010 18:32

I'm pretty new to Linux so this solution may or may not be technically correct...all I know is that I was able to access phpmyadmin afterwards. So consider yourself warned. Anyway, here's what worked for me: Stopped lampp. Went into /opt/lampp/etc/my.conf file and changed the port option from 3306 to 3307. The port setting is in there twice and I changed both of them. Restarted lampp.

It looks like PCLinuxOS 2010 comes with mysql pre-installed and that was trying to use port 3306 as well. I didn't want to uninstall it because it was going to uninstall a bunch of other stuff with it. This seemed to do the trick.

Good luck,
Posts: 1
Joined: 26. April 2010 17:34

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests