running process eating the CPU..

Problems with the Linux version of XAMPP, questions, comments, and anything related.

running process eating the CPU..

Postby utan » 20. April 2010 19:04

So I have my server running xampp I have commented all of the log files even the main xampp config file...
server still doing , I dont know what to do its killing my server anyone know how to disable this for good?
Please help me ....

Code: Select all
29923    nobody    6.0 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    5.5 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log    nobody    
               4.4 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    2.7 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
2      nobody    1.9 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
2   nobody    1.5 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
2   nobody    1.4 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
2   nobody    1.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
2   nobody    1.0 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.9 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.9 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.7 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.7 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.6 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.5 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.4 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.4 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.3 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --use ...
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
   nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
You are invited to visit my site ...http://radioscatrachas.info

thanks a lot..
utan
 
Posts: 14
Joined: 02. June 2009 19:44

Re: running process eating the CPU..

Postby utan » 21. April 2010 00:27

Apache log files still logging I have comment the httpd.conf and vhost.conf and no change, also went to php.ini and turned log_error= off and still cant get it to stop logging its crazy I have like 10 process taking cpu power and this is too much , what can I do to stop, its making my server to slow to death .
Cant find what get it started ....
Anyone could give some insight please or suggest ... here is whats been logged..

Code: Select all
[Tue Apr 20 11:49:31 2010] [notice] Digest: done
[Tue Apr 20 11:49:32 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Apr 20 11:50:37 2010] [notice] caught SIGTERM, shutting down
[Tue Apr 20 11:50:46 2010] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Apr 20 11:50:46 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Apr 20 11:50:46 2010] [notice] Digest: done
[Tue Apr 20 11:50:47 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Apr 20 11:52:21 2010] [notice] caught SIGTERM, shutting down
[Tue Apr 20 11:52:30 2010] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Apr 20 11:52:30 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Apr 20 11:52:30 2010] [notice] Digest: done
[Tue Apr 20 11:52:31 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Apr 20 11:54:50 2010] [notice] caught SIGTERM, shutting down
[Tue Apr 20 11:54:59 2010] [notice] suEXEC mechanism enabled (wrapper: /opt/lampp/bin/suexec)
[Tue Apr 20 11:54:59 2010] [notice] Digest: generating secret for digest authentication ...
[Tue Apr 20 11:54:59 2010] [notice] Digest: done
[Tue Apr 20 11:55:00 2010] [notice] Apache/2.2.14 (Unix) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Tue Apr 20 12:07:16 2010] [notice] caught SIGTERM, shutting down

Since I disabled logging nothing else is getting logged since, but the process still there.. is crazy..
Process As I writing
Code: Select all
6378    nobody    0.2 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6395    nobody    0.2 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6454    nobody    0.2 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6464    nobody    0.2 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6834    nobody    0.2 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6354    nobody    0.1 %    /opt/lampp/sbin/mysqld --basedir=/opt/lampp --datadir=/opt/lampp/var/mysql --use ...
6366    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6368    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6369    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6370    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6371    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6372    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6373    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6374    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6375    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6376    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6377    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6379    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6380    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6381    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6382    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6383    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6384    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6385    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6386    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6387    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6388    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6389    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6390    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6391    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6392    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6393    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6394    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6396    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6429    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6430    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6431    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6432    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6433    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6434    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6435    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6436    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6437    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6439    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6440    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6441    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6442    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6443    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6444    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6453    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6456    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6457    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6458    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6459    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6460    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6461    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6462    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6463    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6465    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6466    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6467    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6468    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6682    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
6697    nobody    0.1 %    /opt/lampp/bin/httpd -k start -DSSL -DPHP5 -E /opt/lampp/logs/error_log
You are invited to visit my site ...http://radioscatrachas.info

thanks a lot..
utan
 
Posts: 14
Joined: 02. June 2009 19:44

Re: running process eating the CPU..

Postby Nobbie » 21. April 2010 12:56

utan wrote:Since I disabled logging nothing else is getting logged since, but the process still there.. is crazy..


No it's not crazy, you are simply lazy. The keyword is RTFM. Any command line option (like -E /opt/lampp/logs/error_log) passed to the httpd process OVERRIDES the settings of httpd.conf

You have to edit the lampp start scripts and find out, where and what sets this option and simply remove it.
Nobbie
 
Posts: 8770
Joined: 09. March 2008 13:04

Re: running process eating the CPU..

Postby utan » 21. April 2010 18:25

Nobbie wrote:
No it's not crazy, you are simply lazy. The keyword is RTFM. Any command line option (like -E /opt/lampp/logs/error_log) passed to the httpd process OVERRIDES the settings of httpd.conf

You have to edit the lampp start scripts and find out, where and what sets this option and simply remove it.

Ok thanks I will look into this see what can I find, and its lack of acknowledge not laziness friend...
You are invited to visit my site ...http://radioscatrachas.info

thanks a lot..
utan
 
Posts: 14
Joined: 02. June 2009 19:44

Re: running process eating the CPU..

Postby utan » 21. April 2010 19:57

I disabled this line in lampp but not avail apache wouldnt start, what else can I do ... could you suggest something else....
Code: Select all
   if testport 443
               then
                  $de && echo "XAMPP: Ein anderer Webserver mit SSL laeuft bereits."
                  $de || echo "XAMPP: Another web server daemon with SSL is already running."
               else
                  $de && echo "XAMPP: Starte Apache mit SSL $phpextra..."
                  $de || echo "XAMPP: Starting Apache with SSL $phpextra..."
                  /opt/lampp/bin/apachectl -k start -DSSL $xampp_apachedefine -E /opt/lampp/logs/error_log
               fi
            else
               $de && echo "XAMPP: Starte Apache..."
               $de || echo "XAMPP: Starting Apache..."
               /opt/lampp/bin/apachectl -k start $xampp_apachedefine -E /opt/lampp/logs/error_log
You are invited to visit my site ...http://radioscatrachas.info

thanks a lot..
utan
 
Posts: 14
Joined: 02. June 2009 19:44


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests