Can't get off of Splash/language page on new install

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Can't get off of Splash/language page on new install

Postby dawemmy » 12. April 2010 07:04

NEW to Ubuntu, New to Xampp
Brand new dual install of windows 7 and ubuntu 9.1
Followed an installation guide (

that installs by tarball then creates the xampp control panel entry via a gedit file in applications on desktop for a ubuntu 9.1 installation.

Before the menu file the xampp localhost page was fine but after adding this gedit file. I get a persistent redirect to http://localhost/xampp/slpah.php.

The control panel application DOES start/stop lampp but in firefox the localhost just parks on splash.php file. I click on english but nothing happens. (nothing happens on the other language choices too)
Cleared cache, rebooted. searched around google and apacheforum then finally broke down signed up for this forum to ask this question.
How do I get the localhost xampp running properly?

I just want to use xampp so that I can install joomla 1.5 and use on a localhost.
Can you suggest a good tutorial to install joomla running on xampp?

Really need help!!
Uninstalled xampp 1.7.3a, downloaded it again, installed again, same thing can't get past the splash page,
( I do do all the security stuff)

downloaded a different version 1.7.2 installed that same result
this time I did not do a reboot but just stopped and restarted lampp
same thing stuck on the splash page
should I delete it?? change the index.php file??
many thanks if someone can throw something at me!! I am at wit's end!
Posts: 1
Joined: 12. April 2010 06:52

Re: Can't get off of Splash/language page on new install

Postby dbusse » 12. July 2010 16:13

I was having exactly the same problem:
Ubuntu 9.10
XAMPP for Linux 1.7.3a
Did standard install.
I enter http://localhost/ in my browser and the splash screen comes up. But clicking on any language link brings me back to the splash screen.

In my case the problem was the permissions on the /opt/lampp/htdocs/xampp/lang/lang.tmp file. When I changed it so all users had read/write privileges on the lang.tmp file the page worked correctly. I figured this out by looking at what the php scripts were doing.
Posts: 1
Joined: 12. July 2010 15:48

[SOLVED] Can't get off of Splash/language page on new instal

Postby breakneck21 » 11. October 2010 07:37

Extract using
tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt
command to /opt . Any other way wont work properly because of permissions.

Kshitij Agarwal
Posts: 1
Joined: 11. October 2010 07:31

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 22 guests