I can't start apache server

Problems with the Linux version of XAMPP, questions, comments, and anything related.

I can't start apache server

Postby cambiadeso » 24. March 2010 13:27

Hello. I'm not english, sorry for my english
I download the xampp 1.3.7a, and I uncompressed that in /opt/lampp.
When i go to start lampp (sudo /opt/lampp/lampp start), the terminal shows a error message like this:
Code: Select all
Starting XAMPP for Linux 1.7.3a...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

what's the problem?
Posts: 1
Joined: 24. March 2010 13:20

Re: I can't start apache server

Postby lightraz » 27. April 2010 15:18


look, I manage to get it working by changing the following parameter in the htppd.conf file which is in the /opt/lampp/etc/ directory

where is written Listen 80 I changed to 50 so it became Listen 50 and that apache error was gone as soon as I restarted lampp....

I hope it may help you guys as well that is encounter the same issue

God bless y'all
Posts: 2
Joined: 27. April 2010 15:11

Re: I can't start apache server

Postby mapron » 03. May 2010 01:28

So,. maybe another program was listening Port 80? As we know, two programs cannot be on one port.
Posts: 2
Joined: 29. April 2010 04:17

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests