Enable fetching remote files under Linux?

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Enable fetching remote files under Linux?

Postby markowe » 24. March 2010 11:53

I am running XAMPP (LAMPP) under Ubuntu Koala, both as-is, out of the box, works great but trying to use web services across the Internet and not getting anywhere. Specifically I am working with an installation of Wordpress and my own WP plugin that uses Magpie to fetch RSS feeds from remote servers (eBay products in this case.). Works fine on shared hosting, but can't get this working on my local machine, just get no response. I believe Magpie uses fopen to fetch the feeds. Does anyone know of a limitation with XAMPP/LINUX that might prevent this? I have set allow_url_fopen to "true" in php.ini (actually, that's allowed by default), so it's not that.

Any suggestions? Thanks.
markowe
 
Posts: 2
Joined: 24. March 2010 11:44

Re: Enable fetching remote files under Linux?

Postby markowe » 24. March 2010 12:35

RESOLVED! The Internet is great, if you ask a question and wait for long enough with no reply then you eventually figure it out yourself!

Just in case anyone else has this issue, it is to do with a setting in the Apache config (httpd.conf) which is in your lampp/etc/ directory. The setting is "ServerName" and should be set to your IP address and port number (usually 80), though I think you can put anything here as long as it's a valid address. By default it is set to "localhost" and remote servers presumably won't or even can't respond to a request from an invalid host name like localhost. I have set this and now I can fetch remote RSS feeds just fine.
markowe
 
Posts: 2
Joined: 24. March 2010 11:44


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests

cron