Apache httpd-2.0.4-21

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Apache httpd-2.0.4-21

Postby mdwCA » 16. January 2004 03:34

:?: Hi,
I am currently running Redhat 9.0 and performed a basic installation, and deselected what appeared to be any apps related to Apache. However after completing the installation there appeared to be still remains of Apache that worked as well.

So I proceeded to install “XAMPP Linux 1.4” that defaulted to /opt directory. Now I noticed that I now have two versions of Apache (httpd-2.0.4-21 and the version that came with XAMPP). The installation was a success and tested both versions of Apache by stopping one and starting the other.

Problem: I am trying to install SubVersion (functions likes CVS) that requires Apache 2.0.48 that comes with XAMPP but it doesn’t recognize or finds it. It just simply says it requires Apache 2.0.48.

Question: Should there be two different copies of Apache installed? If not how do I remove the original? It appears that Webmin targets the original Apache httpd-2.0.4-21, is there away to retarget Webmin to XAMPP Version of Apache?

I assumed that SubVersion isn’t really your problem but curious why it didn’t recognize the current version of Apache that comes with XAMPP. If you have any insight it would be much appreciated.

Thank you for all your work on XAMPP and I like your website as well.

Mal W
Canada
mdwCA
 
Posts: 2
Joined: 15. January 2004 02:18

Postby Oswald » 16. January 2004 10:17

Dear Mal!

At which step of the installation Subversion recognize the "wrong" Apache version? Could you please post the exact message.

Best regards
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Failed Dependencies

Postby mdwCA » 17. January 2004 22:46

Thank you for you quick response!

Here is the error message that I received. It appears to be looking for Apache httpd 2.0.48-0.1 and this is the exact one XAMPP cames with. However Subversion-Server cannot find the Apache Version that XAMPP is package with.

[root@localhost ports]# rpm -ivh subversion-server-0.36.0-8282.rh90.i386.rpm
error: Failed dependencies:
httpd >= 2.0.48-0.1 is needed by subversion-server-0.36.0-8282


If you have any suggestions it ismuch appreciated!


Thanks,

Mal W
Canada
mdwCA
 
Posts: 2
Joined: 15. January 2004 02:18

Postby Oswald » 19. January 2004 15:06

Dear Mal!

Try to add the --nodeps option to the rpm command. It would stop the dependency check.

So you should install the software but if it's working is another matter.

Good luck
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 7 guests