Imagick + XAMPP for Linux

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Imagick + XAMPP for Linux

Postby lderdziuk » 15. March 2010 12:48

Hi there,

after reading many howtos on how to get imagick + lampp working, i've decided to write down my experiences. ;-)

So, to get the imagick working on lampp you'll need the following:
1) a linux system (in my case ubuntu)
2) xampp installed (you may also want to add the bin/ directory of lampp to your PATH)
3) the sources of the php, EXACTLY the same version as in the lampp instalation
4) image magick package for ubuntu installed.

Now, copy the sources of the php to the lampp/include/php directory (create it!), then
cd path_to_lampp/include/php

And then, simply type (if you've added the bin directory of lampp to the path)
sudo pecl install Imagick

otherwise, go to path_to_lampp/bin and type
sudo ./pecl install Imagick

Easy and (in my case) effective. :)

ps. I don't have any installation of apache/php besides the xampp, if you do have one, you should be carefull, especially when the API versions of both differ (that was my case which caused me many problems).

best wishes,
if you have any other questions, write at
lukasz.derdziuk [at] ***

*** -
Posts: 3
Joined: 15. March 2010 12:39

Re: Imagick + XAMPP for Linux

Postby hiddenpearls » 11. August 2010 22:28

Thanks for your post ..
please see this one viewtopic.php?f=17&t=41590 and reply me ASAP
Posts: 7
Joined: 11. August 2010 22:17

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests