Page 1 of 1

Installation problem

PostPosted: 19. February 2010 00:53
by tripwire45
Sorry to introduce myself by posting a problem, but after installing xampp on Ubuntu 8.04, I've hit a few snags.

After downloading the tar file, I first ran the tar xvfz xampp-linux-1.7.3a.tar.gz -C /opt command using sudo. Everything seemed to go well, but I received this message at the end of the process:

tar: Error exit delayed from previous errors

I went ahead and followed the rest of the installation and configuration steps on this page:

When I tried to open the xampp console in a web browser by entering http://localhost in the address bar, all I can see is black text against a white background saying "It works!"

The only clue I have is when I started xampp, one of the messages I got was "XAMPP: Another web server daemon is already running."

I have no idea what other web server daemon is running or how to find out what it is.

Any help would be appreciated.



Re: Installation problem

PostPosted: 19. February 2010 01:39
by tripwire45
Some more information. I discovered an older installation, version 1.5.5. I suspect that's what caused the error message when I unzipped the tar file. I manually deleted the old files and unzipped the new tar file as root and it installed without errors.

However, when I start the services, it says another web service and database service are already running. I still get just It works! when I try http://localhost. Now it's probably just a matter of finding where the other web and database services live and stopping them. Can anyone point me where to look?


Re: Installation problem

PostPosted: 19. February 2010 06:07
by tripwire45
Just thought you should know that I solved the problem. There were instances of apache and mysql already running on my machine. I stopped those services and started xampp and localhost came up. This is where I found the answer, in case anyone else has a similar problem;