cannot write a file on htdocs

Problems with the Linux version of XAMPP, questions, comments, and anything related.

cannot write a file on htdocs

Postby odisseo83 » 08. February 2010 19:37

Hi everybody, I just installed xampp but I cannot save files on htdocs directory. what should I do?

thank you in advance
odisseo83
 
Posts: 7
Joined: 08. February 2010 19:30

Re: cannot write a file on htdocs

Postby merlin38 » 12. February 2010 09:00

You probably use sudo to install xampp.
So the owner of files is ROOT

To see the
use terminal
cd /opt
ls -l
You will see that the owner of lampp is root
Other users don't have rights to write in the folder

Use a terminal launched in root mode
Ubuntu: alt+f2 type: gksudo gnome-terminal
cd /opt/lampp/
You have to choose
-setting the rights for read r , write w , and execute x, to yes for the owner, the owner group, and entire world
it is wrx 111 111 111 in binary, and 777 in octal.
sudo chmod -R /opt/lampp/htdocs 777 (-R is for doing this Recursively for each file and folder within htdocs)
-change the owner and owner group
sudo chown -R nobody:users /opt/lampp/htdocs (between owner and owner group you might have or not :. On ubuntu you have to type it)
Then add your cession_identifier to the group "users" with the appropriate command (i use graphical interface for that, not command-line)

Be careful, don't use xampp as a web server listening to the web. Use a firewall.
merlin38
 
Posts: 6
Joined: 05. February 2010 15:37

Re: cannot write a file on htdocs

Postby odisseo83 » 16. February 2010 07:12

odisseo83 wrote:-change the owner and owner group
sudo chown -R nobody:users /opt/lampp/htdocs (between owner and owner group you might have or not :. On ubuntu you have to type it)
Then add your cession_identifier to the group "users" with the appropriate command (i use graphical interface for that, not command-line)
i tried how you say but I'm a newbie, I did not understood how to add my cession identifier to the group users. could you be more detailed or show me pictures?

odisseo83 wrote:setting the rights for read r , write w , and execute x, to yes for the owner, the owner group, and entire world
it is wrx 111 111 111 in binary, and 777 in octal.
sudo chmod -R /opt/lampp/htdocs 777 (-R is for doing this Recursively for each file and folder within htdocs)

I tried but it does not work. better: the first time it worked, but the other ones it did not
odisseo83
 
Posts: 7
Joined: 08. February 2010 19:30


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests