wrong ELF class

Problems with the Linux version of XAMPP, questions, comments, and anything related. wrong ELF class

Postby Hajah » 03. February 2010 23:24


I'm running ubuntu karmic on 64bit system.
I need to use the scgi module so I used these commands:

cd /tmp/
tar zxfv scgi-1.14.tar.gz
cd scgi-1.14
cd apache2
sudo /opt/lampp/bin/apxs -i -c mod_scgi.c
cd /opt/lampp/etc

nano httpd.conf

#1: Find the other LoadModule lines and add:

LoadModule scgi_module modules/

#2: Goto the end of the file and add:


/opt/lampp/lampp restart

When I restart xampp I get this error:

Cannot load /opt/lampp/modules/ into server: /opt/lampp/modules/ wrong ELF class: ELFCLASS64

It seems that there's a problem with 64bits OS calling 32bit libraries...
How can I fix this?

Thanks in advance
Posts: 1
Joined: 03. February 2010 23:14

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests