Can't Start MySQL

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Can't Start MySQL

Postby mrwichtig » 31. January 2010 17:14

ello to all,

From a fresh ubuntu 9.10 install I can sucessfully run LAMPP until I set the security settings.

This is what I do


sudo tar -zxvf xampp-linux-1.7.3a.tar.gz -C /opt
sudo /opt/lampp/lampp start


Starting XAMPP for Linux 1.7.3a...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

And everything just work.

Component Status Hint
MySQL database ACTIVATED
PHP ACTIVATED
Perl ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED



Now:

sudo /opt/lampp/lampp security

XAMPP: Quick security check...
XAMPP: Your XAMPP pages are NOT secured by a password.
XAMPP: Do you want to set a password? [yes] y
XAMPP: Password:
XAMPP: Password (again):
XAMPP: Password protection active. Please use 'lampp' as user name!
XAMPP: The MySQL/phpMyAdmin user pma has no password set!!!
XAMPP: Do you want to set a password? [yes] y
XAMPP: Password:
XAMPP: Password (again):
XAMPP: Setting new MySQL pma password.
XAMPP: Setting phpMyAdmin's pma password to the new one.
XAMPP: MySQL has no root passwort set!!!
XAMPP: Do you want to set a password? [yes] y
XAMPP: Write the password somewhere down to make sure you won't forget it!!!
XAMPP: Password:
XAMPP: Password (again):
XAMPP: Setting new MySQL root password.
XAMPP: Change phpMyAdmin's authentication method.
XAMPP: The FTP password for user 'nobody' is still set to 'lampp'.
XAMPP: Do you want to change the password? [yes] y
XAMPP: Password:
XAMPP: Password (again):
XAMPP: Reload ProFTPD...
XAMPP: Done.

Now this is what I get:

Component Status Hint
MySQL database DEACTIVATED
PHP ACTIVATED
Perl ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED

-------------------

What am I missing?

Please help ! thanks in advance.

Mr.W
mrwichtig
 
Posts: 3
Joined: 31. January 2010 17:03

Re: Can't Start MySQL

Postby Wiedmann » 31. January 2010 20:15

Is phpMyAdmin working?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't Start MySQL

Postby mrwichtig » 01. February 2010 05:33

Yes, seems to be working. I can log in with root/pass. Very Strange.
mrwichtig
 
Posts: 3
Joined: 31. January 2010 17:03

Re: Can't Start MySQL

Postby Wiedmann » 01. February 2010 08:20

So this page is showing you a wrong status and you can ignore it.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't Start MySQL

Postby mrwichtig » 03. February 2010 05:34

is no matter of wrong status.

I said phpmyadmin works because I can log in with root account... I can log in create databases, users etc but nothing else.

With a fresh install of ubuntu 9.10, did every step mentioned in xampp homepage, right from the box all worked ok until I ran sudo /opt/lampp/lampp security.
You may think I did something wrong here, but I cant go wrong with "yes/no" answers and giving all the same password, and doing nothing
else than check the example pages of xampp. The examples pages didnt work anymore right after security script.

Now I had to set up "manually" php apache and mysql the old good way with my distro repositories and messing with config files,
I had to give up on xampp for the moment.


Hint:
In security settings if I dont give a root password to mysql, seems to work.
mrwichtig
 
Posts: 3
Joined: 31. January 2010 17:03

Re: Can't Start MySQL

Postby Wiedmann » 03. February 2010 08:46

I said phpmyadmin works because I can log in with root account... I can log in create databases, users etc but nothing else.

What's not working in phpMyAdmin?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: Can't Start MySQL

Postby tripwire45 » 19. February 2010 06:10

I've just installed xampp on Ubuntu 8.04 and am having the exact same problem. I've done a fair amount of searching and am wondering if it's a bug. It seems like this question is asked a lot on the web, but there isn't a definitive answer. Establishing one and putting in the FAQ for xampp for linux would be a great help.

Thanks.

EDIT: There seems to be a solution in the xampp for windows forum. Would it apply to Linux? viewtopic.php?f=16&t=36652&start=0#p147095
tripwire45
 
Posts: 5
Joined: 19. February 2010 00:43

Re: Can't Start MySQL

Postby MC10 » 21. February 2010 20:03

I believe it should, but what does it say in your file?
MC10
 
Posts: 148
Joined: 20. February 2010 20:13

Re: Can't Start MySQL

Postby tripwire45 » 22. February 2010 01:27

Sorry...what does it say in which file? Here's what's displayed for XAMPP status:

MySQL database DEACTIVATED
PHP ACTIVATED
Perl ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED
PHP extension »eAccelerator« DEACTIVATED see FAQ
PHP extension »OCI8/Oracle« DEACTIVATED see FAQ

The database definitely works, so I'm at a loss.
tripwire45
 
Posts: 5
Joined: 19. February 2010 00:43

Re: Can't Start MySQL

Postby MC10 » 23. February 2010 04:13

The "/lampp/htdocs/xampp/mysql.php" file (or similar on UNIX system).
MC10
 
Posts: 148
Joined: 20. February 2010 20:13


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 2 guests