Error `GLIBC_2.3' not found - PLEASE HELP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Error `GLIBC_2.3' not found - PLEASE HELP

Postby andy122 » 07. December 2009 09:48

XAMPP 1.7.2
System ASPLinux 7.3 pylesos.asp-linux.com.ua 2.4.9-31smp year 2002
Linux Kernel 2.4.18
glibc-2.2.5
Processor Intel Pentium-III-800

I gel following error messages

Starting XAMPP for Linux 1.7.2...
/opt/lampp/bin/php: error while loading shared libraries: libgcc_s.so.1: cannot open shared object file: No such file or directory
XAMPP: Starting Apache with SSL ...
/opt/lampp/bin/httpd: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/bin/httpd)
/opt/lampp/bin/httpd: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/lib/libaprutil-1.so.0)
/opt/lampp/bin/httpd: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /opt/lampp/lib/libapr-1.so.0)
/opt/lampp/bin/httpd: /lib/i686/libc.so.6: version `GLIBC_2.3.2' not found (required by /opt/lampp/lib/libapr-1.so.0)
/opt/lampp/bin/httpd: /lib/i686/libc.so.6: version `GLIBC_2.3.3' not found (required by /opt/lampp/lib/libapr-1.so.0)
/opt/lampp/bin/httpd: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/lib/libapr-1.so.0)
XAMPP: Error 1! Couldn't start Apache!
XAMPP: Starting diagnose...
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
/opt/lampp/bin/my_print_defaults: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/bin/my_print_defaults)
/opt/lampp/bin/my_print_defaults: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /opt/lampp/bin/my_print_defaults)
/opt/lampp/bin/my_print_defaults: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/bin/my_print_defaults)
/opt/lampp/bin/my_print_defaults: /lib/i686/libpthread.so.0: version `GLIBC_2.3.2' not found (required by /opt/lampp/bin/my_print_defaults)
XAMPP: Couldn't start MySQL!
XAMPP: Starting ProFTPD...
XAMPP: /opt/lampp/sbin/proftpd: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/sbin/proftpd)
/opt/lampp/sbin/proftpd: /lib/i686/libc.so.6: version `GLIBC_2.3.4' not found (required by /opt/lampp/sbin/proftpd)
/opt/lampp/sbin/proftpd: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/lib/mysql/libmysqlclient.so.16)
/opt/lampp/sbin/proftpd: /lib/i686/libc.so.6: version `GLIBC_2.3' not found (required by /opt/lampp/lib/libcrypto.so.0.9.8)
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for Linux started.

All glibc packages are carefuly found and loaded fron distribution CDs.

PLEASE ADVICE.
Maybe ASP Linux 7.3 is too old for running XAMPP 1.7.2 and I need older XAMPP?
Which XAMPP will fit to this?

Thank you.
Andrey
Moscow Russia.
a8811@yandex.ru
andy122
 
Posts: 2
Joined: 07. December 2009 09:28

Re: Error `GLIBC_2.3' not found - PLEASE HELP

Postby andy122 » 07. December 2009 15:12

Thank you very much for your replies.

[2008-09-24] XAMPP for Linux 1.6.8a really works well on this equipment.

Bye.
andy122
 
Posts: 2
Joined: 07. December 2009 09:28


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 9 guests