File Reading / Saving permissions

Problems with the Linux version of XAMPP, questions, comments, and anything related.

File Reading / Saving permissions

Postby bizugo » 18. November 2009 19:46

failed to open stream: Permission denied

Everything in the site works only the I/O file don't work, using file_get_contents and file_put_contents.

I tried to change the file target to 777 also the php scripts but nothing happens.
Target file isn't in /opt/lampp/htdocs

I tried to add the user nobody to some groups (disk, root, adm, sys, bin), but don't worked too them i removed the groups.

Is there any way to make the i/o file system works without changing the target files owner (cause i can't change the owner using the chown)?

OS: centos

PS: I changed the owner of the directory and still not able to write / read from there... The permission is 777 and still not able to write / read o0'
bizugo
 
Posts: 1
Joined: 18. November 2009 19:40

Re: File Reading / Saving permissions

Postby Brabax » 21. November 2009 22:46

Maybe the PHP Safe-Mode is enabled ...

Brabax
We've already reached tomorrow's yesterday but we're still far away from yesterday's tomorrow.
User avatar
Brabax
 
Posts: 30
Joined: 04. April 2003 18:37
Location: Espelkam*


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests