phpunit

Problems with the Linux version of XAMPP, questions, comments, and anything related.

phpunit

Postby joeradtke » 18. November 2009 03:54

I would like to use php unit in my xampp installation.

There is a PHPUnit.php file in /opt/lampp/lib/php as well as a PHPUnit directory. Using phpunit from the command line gives an error that it is not installed.

I have tried installing it from PEAR but this gives an extra copy in the /usr directory which will not work to run my tests. I ended up deleting all these files as well as my /opt/lampp directory and resinstalling xampp.

I can get the thing started by writing a program to run PHPUnit.php but some of the includes are missing such as PHPUnit/Framework.php and the directory PHPUnit/Framework et al.

I have tried researching this and have come to the conclusion that phpunit is provided with xampp. However, I don't have a clue how to make it work. Most of the research turns up sites that describe using it with windows.

I really like xampp but it often takes a bit of research to find out how to do something as the files are placed differently than with a standard Apache installation.

Any help would be appreciated.

Joe Radtke
joeradtke
 
Posts: 1
Joined: 19. January 2009 20:57

Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests