i'm can't start XAMPP

Problems with the Linux version of XAMPP, questions, comments, and anything related.

i'm can't start XAMPP

Postby fate_project » 30. September 2009 22:08

Hello, i'm from mexico and my english is bad... sorry XD


i'm can't start xampp on Ubuntu 9.4, I did everything the guide said, but it makes this error:

Image

which will be the problem?

thanks and sorry, i bad on english. XD
fate_project
 
Posts: 3
Joined: 30. September 2009 21:54

Re: i'm can't start XAMPP

Postby Nobbie » 01. October 2009 09:32

Look into error_log file /opt/lampp/logs/error_log
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: i'm can't start XAMPP

Postby SirGallo » 01. October 2009 21:16

i have the same problem...

My file /opt/lampp/logs/error_log :

Code: Select all
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs


I don't understand this message, what happen ?
SirGallo
 
Posts: 1
Joined: 01. October 2009 21:12

Re: i'm can't start XAMPP

Postby Nobbie » 01. October 2009 22:40

SirGallo wrote:I don't understand this message, what happen ?


Port 80 is already in use on your PC.

Most cases you have either Skype installed and working on port 80, or Microsoft IIS is installed and blocks port 80.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: i'm can't start XAMPP

Postby fate_project » 01. October 2009 23:11

Nobbie wrote:Look into error_log file /opt/lampp/logs/error_log



this is my file log:


Image


----------------------------------------------------------------

about port 80:


i don't have Skype in my PC, and Microsoft IIS is for DataBases,no? I don't have IIS

But, in Windows i have installed WAMP in Disk C: and i use the localhost, and myadmin without problems.

if port 80 is blocked as unlocking?


Thanks for your answers
fate_project
 
Posts: 3
Joined: 30. September 2009 21:54

Re: i'm can't start XAMPP

Postby lkause » 02. October 2009 05:37

It is most likely your WAMP server in Windows that is using port 80 (this is assuming you are using Virtual PC 2007 or VMWare that has Ubuntu installed).

If you are using a virtual machine to host Ubuntu, change the network settings in VMWare machine and change the network settings to "Bridged". In Virtual PC 2007, change the network settings to "Virtual Machine Network Driver".

Your (Host)Windows machine and (Guest) Ubuntu Virtual box will have 2 different IP addresses if you are using a router, and you will be able to use both successfully.

------ if the above does not apply ------

change the server settings used by WAMP or XAMPP to use different ports.

LK
lkause
 
Posts: 6
Joined: 28. September 2009 05:39

Re: i'm can't start XAMPP

Postby fate_project » 02. October 2009 23:51

lkause wrote:It is most likely your WAMP server in Windows that is using port 80 (this is assuming you are using Virtual PC 2007 or VMWare that has Ubuntu installed).

If you are using a virtual machine to host Ubuntu, change the network settings in VMWare machine and change the network settings to "Bridged". In Virtual PC 2007, change the network settings to "Virtual Machine Network Driver".

Your (Host)Windows machine and (Guest) Ubuntu Virtual box will have 2 different IP addresses if you are using a router, and you will be able to use both successfully.

------ if the above does not apply ------

change the server settings used by WAMP or XAMPP to use different ports.

LK



i don't use a Virtual Machine for Ubuntu.

i will change the port of xampp, maybe the problem is resolved

thanks for answering
fate_project
 
Posts: 3
Joined: 30. September 2009 21:54


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests