xampp start problem

Problems with the Linux version of XAMPP, questions, comments, and anything related.

xampp start problem

Postby shadwdragn » 21. September 2009 23:34

Hey, when i try to start up xampp in terminal i get this:
Starting XAMPP for Linux 1.7.2...
XAMPP: Another web server daemon is already running.
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.


I checked the faq and it said i need to stop the daemon. I cant find were or what it is or how to stop it. Thanks,

David
shadwdragn
 
Posts: 1
Joined: 21. September 2009 23:28

Re: xampp start problem

Postby n4zroth » 27. September 2009 22:54

Hi, I got a similar problem, but first I try to suggest some help:
Have you got any other webserver/mysql-server installed? If you don't know, try finding out with
dpkg -l *mysql*
dpkg -l *apache*
If you see them, try either stopping them with eg /etc/init.d/apache stop and /etc/init.d/mysqld stop.
If not, try finding out which programs eventually might block your ports with netstat -tulpen and look for the applications.
It might be helpful to know where the programs are located, so try finding out with locate $name (apt-get install dlocate) or use find. But for easy applications, I prefer locate.

To my problem:
XAMPP: Couldn't start MySQL!
The other daemons start w/o any errors.
When I try it with /opt/lampp/sbin/mysqld start, it tells my I shouldn't run it as root. But that's what I have to do to run xampp, don't I?
Thanks for your help and I helped I could help the person above me a little :)
n4zroth
 
Posts: 3
Joined: 27. September 2009 22:47

Re: xampp start problem

Postby n4zroth » 27. September 2009 23:31

090928 00:28:39 mysqld_safe Starting mysqld daemon with databases from /opt/lampp/var/mysql
090928 0:28:39 [Note] Plugin 'FEDERATED' is disabled.
^G/opt/lampp/sbin/mysqld: Can't find file: './mysql/plugin.frm' (errno: 13)
090928 0:28:39 [ERROR] Can't open the mysql.plugin table. Please run mysql_upgrade to create it.
090928 0:28:40 InnoDB: Operating system error number 13 in a file operation.
InnoDB: The error means mysqld does not have the access rights to
InnoDB: the directory.
InnoDB: File name /opt/lampp/var/mysql/ibdata1
InnoDB: File operation call: 'open'.
InnoDB: Cannot continue operation.
090928 00:28:40 mysqld_safe mysqld from pid file /opt/lampp/var/mysql/debian.pid ended
I found the error file, is debian.err the right one?
But I can't use mysql_upgrade as MySQL ain't running. So what? :(
n4zroth
 
Posts: 3
Joined: 27. September 2009 22:47

Re: xampp start problem

Postby n4zroth » 27. September 2009 23:42

Oh well, I just found this topic (hadn't seen it before): viewtopic.php?f=17&p=141169
Solution (for me) was sudo chown -R nobody /opt/lampp/
Now it works fine.
n4zroth
 
Posts: 3
Joined: 27. September 2009 22:47


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests