Downgrade php to 5.2.11 in lastest xampp installation

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Downgrade php to 5.2.11 in lastest xampp installation

Postby wintertong » 20. September 2009 21:11

I have to install the latest version of xampp because one of our clients has failed a bank pci check. They are
enforcing that our servers are running apache 2.2.12 and php 2.2.10 or greater. The latest xampp covers this but
php 5.3 is breaking magento which is not supported yet in this version.

I need to downgrade php to 5.2.11.

How do I do this? It must be possible? Can anyone help?

Regards gareth
wintertong
 
Posts: 3
Joined: 01. May 2009 12:01

Re: Downgrade php to 5.2.11 in lastest xampp installation

Postby nolroz » 01. October 2009 07:57

I have the same problem. I want desperately to solve this one. I think I'm just going to downgrade xampp to 1.7,1. It has php 5.29, which will let me run drupal.
nolroz
 
Posts: 1
Joined: 01. October 2009 06:07

Re: Downgrade php to 5.2.11 in lastest xampp installation

Postby wintertong » 01. October 2009 08:17

Hi,

No one seems to want to reply to this, even if it is to say that it is not possible.

I can't go to 5.2.9 as this is not PCI compliant.

If you hear of anything, please let me know.

Regards Gareth
wintertong
 
Posts: 3
Joined: 01. May 2009 12:01

Re: Downgrade php to 5.2.11 in lastest xampp installation

Postby ollu » 01. October 2009 14:01

I also would like to now how this is done. I installed the latest xampp and was going to install the latest version of drupal. Version 6 of drupal makes use of the ereg() function which is deprecated from version 5.3 of php. So I need to install an earlier version of php to be able to install drupal.
ollu
 
Posts: 2
Joined: 30. September 2009 21:16

Re: Downgrade php to 5.2.11 in lastest xampp installation

Postby freed » 30. October 2009 14:53

I also need a solution for this. Joomla 1.5.7 does not support PHP 5.3. I am on OS X and and installing the 1.01 build of XAMPP as a workaround. I would much rather just downgrade the version of PHP. Thanks for any information!!
freed
 
Posts: 1
Joined: 30. October 2009 14:46

Re: Downgrade php to 5.2.11 in lastest xampp installation

Postby Kuze » 02. November 2009 19:19

This isn't tested but maybe try executing:

/opt/lampp/share/lampp/activatephp 5.2.9
Kuze
 
Posts: 3
Joined: 26. October 2009 21:00

Re: Downgrade php to 5.2.11 in lastest xampp installation

Postby trikks » 04. November 2009 11:00

Install PHP via macports, try to follow this guide
http://trikks.wordpress.com/2009/10/07/ ... rd-server/

However, the some of the path's might be different, like /etc/apache2/httpd.conf. Just find out the ones used by xampp and you'll be fine! :)
trikks
 
Posts: 1
Joined: 04. November 2009 10:49


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 11 guests