xampp not able to start it's apache service

Problems with the Linux version of XAMPP, questions, comments, and anything related.

xampp not able to start it's apache service

Postby abhijit_mohanta » 14. September 2009 08:10

I need to run another instance (apart from xampp) of apache on my system.
When I m starting xampp with port changed(changed httpd.conf to listen on different port).
I am getting error "another instance of httpd daemon" running.How should I start xampp.
abhijit_mohanta
 
Posts: 1
Joined: 14. September 2009 07:47

Re: xampp not able to start it's apache service

Postby Axanon » 15. September 2009 16:52

I've looked for some solutions to your problem, unfortunately they require you to build your own Apache/PHP from source. Since the few methods I've read are slightly different, I suggest Googling it and look for the way that suits your needs best.

Although I'm not certain why you would need multiple instances of apache running, a band-aid fix could be to setup a Virtual Machine (Like Virtual Box) and install a (CLI) linux distro and run your secondary web server from that. It's probably not too helpful if you need both servers up all the time, it's just a suggestion.
Axanon
 
Posts: 7
Joined: 15. September 2009 16:36

Re: xampp not able to start it's apache service

Postby dmphotography » 15. September 2009 19:01

abhijit_mohanta wrote:I need to run another instance (apart from xampp) of apache on my system.
When I m starting xampp with port changed(changed httpd.conf to listen on different port).
I am getting error "another instance of httpd daemon" running.How should I start xampp.


I'm guessing you've already installed the other instance of Apache, correct?

Try stopping it, which you should be able to do using apache2ctl stop.
Then start XAMPP, which should be /opt/lampp/lampp start.

If XAMPP starts without any problems, check to see if you can access it via http://localhost/ .
If so, somewhere you've missed setting the ports correctly, because it's still accessing it on port 80.

Otherwise, you should have to enter http://localhost:1234/ , with 1234 being the new port number you specified.
If this works and port 80 didn't, I'm not sure what would be conflicting, because in theory it should work.

I haven't ever tried running two Apache servers simultaneously, so that's about all I can think for it to be.

If you need a page to be available on a different port, you might aught to look into configuring a VirtualHost in your settings file to listen on the other port instead of trying to run another instance of Apache.

You can have an Apache server that listens on multiple ports and based on what port the traffic comes in on, you can tell it what page to display. This would make more sense, unless you have a specific reason for doing it the way you're trying to do it.
For great video and written tutorials and guides on creating your own web server and installing things such as forums, blogs, etc., visit http://myownhomeserver.com
dmphotography
 
Posts: 191
Joined: 15. December 2008 14:25
Location: Columbus, MS
Operating System: Windows 7

Re: xampp not able to start it's apache service

Postby verbomania » 29. September 2009 19:39

I was struggling with this despite having changed the settings in httpd.conf and everywhere I could find reference to port 80, xampp still refused to start up with the "another daemon" message. I then did the obvious thing and looked at the ./lampp start up script. It contains a test to see if the port is in use before starting Apache and the test is hardcoded to port 80. So it doesn't matter what you change on the config, lampp will not start.

Simply edit the lampp startup script. The testport call is round line 191 change the port number from 80 to your desired port number and away you go.
verbomania
 
Posts: 1
Joined: 29. September 2009 19:34


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests