lower_case_table_names not taking effect

Problems with the Linux version of XAMPP, questions, comments, and anything related.

lower_case_table_names not taking effect

Postby rays » 08. September 2009 14:21

I tried setting lower_case_table_names = 1 in /opt/lampp/etc/my.conf. I am using XAMPP 1.7 on Ubuntu 9.04 server

After several attempts and restarts the variable doesn't seem to take effect. I queried using

mysqladmin -u root variables | grep "lower_case_table_names"

and get the output 0

I am planning to switch to mysql from Ubuntu repo but before that wanted to check if I am missing something or is this a bug. The documentation of XAMPP suggests this is the right conf file.
rays
 
Posts: 3
Joined: 08. September 2009 14:04

Re: lower_case_table_names not taking effect

Postby Wiedmann » 08. September 2009 14:49

I tried setting lower_case_table_names = 1 in /opt/lampp/etc/my.conf.

I don't think "my.conf" is the correct file. IMHO it is "my.cnf".

And you must add this to the correct section in this file.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: lower_case_table_names not taking effect

Postby rays » 08. September 2009 14:53

Ouch! I did mean my.cnf even though I ended up writing my.conf... Typo ... thanks for pointing out.

You mention the right section.. Can you throw some pointers? I just added it to the end of the file.

Thanks
rays
 
Posts: 3
Joined: 08. September 2009 14:04

Re: lower_case_table_names not taking effect

Postby rays » 08. September 2009 15:12

I think the correct section hint was very useful. I just moved it under MySQL server section and things worked ;-)

Even though I had read through this section it didn't strike me that the location would matter.

Many Thanks
rays
 
Posts: 3
Joined: 08. September 2009 14:04


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests