Page phpSQLiteAdmin is not working. XAMPP for Linux 1.7.2

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Page phpSQLiteAdmin is not working. XAMPP for Linux 1.7.2

Postby Will-BR » 30. August 2009 23:49

I am having problems with the site phpSQLiteAdmin.
It appears that on the screen:

Deprecated: Assigning the return value of new by reference is deprecated in / opt / lampp / phpSQLiteAdmin / include.php on line 30

Deprecated: Assigning the return value of new by reference is deprecated in / opt / lampp / phpSQLiteAdmin / include.php on line 36

Deprecated: Assigning the return value of new by reference is deprecated in / opt / lampp / phpSQLiteAdmin / include.php on line 38


What should I do to fix?
Thanks for attention.
Will-BR
 
Posts: 1
Joined: 30. August 2009 23:27

Re: Page phpSQLiteAdmin is not working. XAMPP for Linux 1.7.2

Postby stacia » 03. January 2010 00:01

bump. I'm getting this too but with an extra error:


Code: Select all
Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/phpsqliteadmin/include.php on line 30

Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/phpsqliteadmin/include.php on line 36

Deprecated: Assigning the return value of new by reference is deprecated in /opt/lampp/phpsqliteadmin/include.php on line 38

Notice: Undefined index: phpSQLiteAdmin_currentdb in /opt/lampp/phpsqliteadmin/include.php on line 9


Help please?
stacia
 
Posts: 3
Joined: 25. August 2009 02:15

Re: Page phpSQLiteAdmin is not working. XAMPP for Linux 1.7.

Postby helkav » 01. January 2012 19:40

I got these errors too. I think it's because PHP 5.3+ has stricter type checking than prev. versions and this code may have been written with an older version of PHP?

change all statements in include.php like this:

$sysdbh =& new SPSQLite('phpsla.sqlite');

to this

$sysdbh = new SPSQLite('phpsla.sqlite');

for the last error I commented out funtion update - I don't know the consequences of that yet! I will have to see!

/*
function update($this)
{
}
*/

anyway it's up and running now - I will post an update if I need to make more fixes.

I believe there is a way to turn off the deprecated errors e.g.

error_reporting(E_ALL & ~E_NOTICE & ~E_DEPRECATED);

but I think in this instance it's not much code to fix
helkav
 
Posts: 1
Joined: 01. January 2012 19:15
XAMPP Version: 1.8.3-3
Operating System: Windows 7 64 bit


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests