upgrading from 1.7.1 to 1.7.2 fails

Problems with the Linux version of XAMPP, questions, comments, and anything related.

upgrading from 1.7.1 to 1.7.2 fails

Postby mvdberg » 11. August 2009 13:23

Hello,

I tried to upgrade from 1.7.1 to 1.7.2 using the upgrade package.
Here is what I did and what the response is:

xampp-upgrade/start
Stopping XAMPP for Linux 1.7.1...
XAMPP: Stopping Apache with SSL...
XAMPP: Stopping MySQL...
XAMPP: Stopping ProFTPD...
XAMPP stopped.

Upgrading 1.7.1 to 1.7.2...
Installing new files...
Upgrading existing files...
patching file `lampp/etc/pear.conf'
The file /opt/lampp/etc/php.ini couldn't be upgraded.
The new version of the file could be found under: /opt/lampp/etc/php.ini-1.7.2
patching file `lampp/etc/webalizer.conf.sample'
patching file `lampp/phpmyadmin/config.inc.php'
Hunk #1 succeeded at 21 with fuzz 1 (offset 2 lines).

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Please call '/opt/lampp/bin/mysql_upgrade -p' to update MySQL databases to the new MySQL version.

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!


There were some problems during the upgrade. But don't panic! :)
Please read http://www.apachefriends.org/faq-lampp-en.html#undnun for assistance.


Then I did: /opt/lampp/lampp startmysql
Then: /opt/lampp/bin/mysql_upgrade -p
response was OK

Then: /opt/lampp/lammp stop
response:
Stopping XAMPP for Linux 1.7.2...
XAMPP: XAMPP-Apache is not running.
XAMPP: Stopping MySQL...
XAMPP: XAMPP-ProFTPD is not running.
XAMPP stopped.


Then: /opt/lampp/lampp start
response:
Starting XAMPP for Linux 1.7.2...
PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0
PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20090626/dbx.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20090626/dbx.so: cannot open shared object file: No such file or directory in Unknown on line 0
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.



What to do now????
mvdberg
 
Posts: 2
Joined: 11. August 2009 13:14

Re: upgrading from 1.7.1 to 1.7.2 fails

Postby Wiedmann » 11. August 2009 13:35

PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0

Change to:
Code: Select all
magic_quotes_gpc = Off


PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20090626/dbx.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20090626/dbx.so: cannot open shared object file: No such file or directory in Unknown on line 0

Remove:
Code: Select all
extension=dbx.so


The file /opt/lampp/etc/php.ini couldn't be upgraded.
The new version of the file could be found under: /opt/lampp/etc/php.ini-1.7.2

And maybe compare "php.ini" with "php.ini-1.7.2" yourself.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: upgrading from 1.7.1 to 1.7.2 fails

Postby mvdberg » 11. August 2009 13:44

Thanks.
It's running.
mvdberg
 
Posts: 2
Joined: 11. August 2009 13:14

Re: upgrading from 1.7.1 to 1.7.2 fails

Postby bigpcman » 16. August 2009 17:23

Wiedmann wrote:
PHP Warning: Directive 'magic_quotes_gpc' is deprecated in PHP 5.3 and greater in Unknown on line 0

Change to:
Code: Select all
magic_quotes_gpc = Off

Please forgive my ignorance, but what file is being modified in the above change?

PHP Warning: PHP Startup: Unable to load dynamic library '/opt/lampp/lib/php/extensions/no-debug-non-zts-20090626/dbx.so' - /opt/lampp/lib/php/extensions/no-debug-non-zts-20090626/dbx.so: cannot open shared object file: No such file or directory in Unknown on line 0

Remove:
Code: Select all
extension=dbx.so

Please forgive my ignorance, but what file is being modified in the above change?

The file /opt/lampp/etc/php.ini couldn't be upgraded.
The new version of the file could be found under: /opt/lampp/etc/php.ini-1.7.2

And maybe compare "php.ini" with "php.ini-1.7.2" yourself.

Could you please provide some insight as to why these changes are necessary? Will all users be affected and require these changes?
bigpcman
 
Posts: 39
Joined: 11. January 2009 15:52


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 5 guests