LAMPP's cURL unable to resolve hosts

Problems with the Linux version of XAMPP, questions, comments, and anything related.

LAMPP's cURL unable to resolve hosts

Postby bkanber » 22. July 2009 04:22

Hey guys,

I'm having some trouble with curl on a LAMPP install. I'm running Ubuntu Jaunty. I have a similar install, and it all worked fine.

My "normal" curl (ie, the one installed from apt-get) works fine when I run, say "curl google.com" from the command line.

However, running curl EITHER from PHP or from the following command: "/opt/lampp/bin/curl google.com" returns "curl: (6) Couldn't resolve host 'google.com'".

I don't know where to look, really (I'm just a lowly programmer, not really a sysadmin). My /etc/resolv.conf looks something like:
# Generated by NetworkManager
domain rnxn4ps
search rnxn4ps
nameserver 208.67.222.222
nameserver 4.2.2.2

Anyone have any ideas?

Thanks in advance,
Burak
bkanber
 
Posts: 1
Joined: 22. July 2009 04:17

Re: LAMPP's cURL unable to resolve hosts

Postby caltuna » 01. August 2009 22:32

caltuna
 
Posts: 111
Joined: 05. May 2009 16:35


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 4 guests