Stop directory listing in Apache - Help!

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Stop directory listing in Apache - Help!

Postby BiL0 » 10. July 2009 11:54

Hello,
I've been using XAMPP for sometimes on Ubuntu 8.04 server
what I noticed is that if I put a partial URL then I get the directory listing of the previous directory which I think is a security problem.
I tried to search for Apache but all refer to an Apache2.conf which I think the XAMMP does't use.
Can you please let me know how to stop this from happening.
thank you in advance for your reply
BiL0
BiL0
 
Posts: 2
Joined: 10. July 2009 11:46

Re: Stop directory listing in Apache - Help!

Postby Nobbie » 10. July 2009 12:36

If you installed Xampp and use Xampp, the configuration of Apache takes place in /opt/lampp/etc/httpd.conf

You should look for the "Options Indexes" which causes directory listings.
Nobbie
 
Posts: 8779
Joined: 09. March 2008 13:04

solved: Stop directory listing in Apache - Help!

Postby BiL0 » 10. July 2009 17:06

thank you

I had to add the - in front of Indexes and it has worked
this is good
so I have
Option Indexes FllowSymLinks etc etc
and I changed it for
Option -Indexes FllowSymLinks etc etc
:o)
that was easy
thank you all
BiL0
BiL0
 
Posts: 2
Joined: 10. July 2009 11:46


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 12 guests