XAMPP on Redhat

Problems with the Linux version of XAMPP, questions, comments, and anything related.

XAMPP on Redhat

Postby sib » 08. July 2009 23:54

Hi,

I am not new to XAMPP, have been using it on Windows for a couple of years now, without any issues. A great app I must say!!

Today, however, for the first time I had to install it on a client's Linux server and I followed all the mentioned steps very carefully, yet am getting the following error:

Code: Select all
# /opt/lampp/lampp start
Starting XAMPP for Linux 1.7.1...
XAMPP: Starting Apache with SSL (and PHP5)...
/opt/lampp/bin/httpd: relocation error: /opt/lampp/lib/libapr-1.so.0: symbol sys_siglist, version GLIBC_2.3.3 not defined in file libc.so.6 with link time reference
XAMPP: Error 127! Couldn't start Apache!
XAMPP: Starting diagnose...
tail: /opt/lampp/logs/apachestart.log: No such file or directory
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP: /opt/lampp/sbin/proftpd: /lib/libc.so.6: version `GLIBC_2.3.4' not found (required by /opt/lampp/sbin/proftpd)
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for Linux started.


Any idea what this could mean and how can I rectify this?

Thanks,
Sib.
sib
 
Posts: 2
Joined: 08. July 2009 23:48

Re: XAMPP on Redhat

Postby Nobbie » 09. July 2009 08:19

Maybe you are running a 64bit Linux and installed 32bit Xampp?
Nobbie
 
Posts: 8780
Joined: 09. March 2008 13:04

Re: XAMPP on Redhat

Postby sib » 14. July 2009 15:53

Hi thanks for replying..
Well, I checked with my client, its 32bit Linux
But anyway, my client ordered a root server with everything already pre-installed, so things are working fine now :)
Thanks.
sib
 
Posts: 2
Joined: 08. July 2009 23:48

Re: XAMPP on Redhat

Postby flawed » 15. July 2009 06:42

i recieved the exact same error just now. i installed redhat 9, on an old hp netserver, so i KNOW it's not 64 bit
and i am certain i grabbed the 32bit xampp

Code: Select all
XAMPP: Error 127! Couldn't start Apache!
XAMPP: Starting diagnose...
tail: /opt/lampp/logs/apachestart.log: No such file or directory
XAMPP: Sorry, I've no idea what's going wrong.
XAMPP: Please contact our forum http://community.apachefriends.org/f/
XAMPP: XAMPP-MySQL is already running.
XAMPP: Starting ProFTPD...
XAMPP: /opt/lampp/sbin/proftpd: /lib/libc.so.6: version `GLIBC_2.3.4' not found
(required by /opt/lampp/sbin/proftpd)
XAMPP: Error 1! Couln't start ProFTPD!
XAMPP for Linux started.
[root@localhost root]#


anyone got any suggestions for what could cause this error?
flawed
 
Posts: 2
Joined: 15. July 2009 06:37

Re: XAMPP on Redhat

Postby caltuna » 15. July 2009 07:19

Looks like you need to update libc6. Don't know how you would do it in RH but in Debian/Ubuntu it would be:
sudo apt-get --reinstall install libc6
caltuna
 
Posts: 111
Joined: 05. May 2009 16:35

Re: XAMPP on Redhat

Postby flawed » 16. July 2009 01:19

ok, no, apt doesn't automatically work on redhat 9...
i followed the instructions here

Code: Select all
Go to http://apt.freshrpms.net/ and get the appropriate version for your system. Easiest way to get it: "cd /tmp", "wget <url of rpm>".
If you're not sure of your version, use rpm -v and compare to what's on that site.
NOTE ON RH AS 2.1 Oddly enough, despite what you might expect, RedHat Advanced Server 2.1 seems to be closer to RH 7.2 then 7.3. If you go with 7.3 in your apt sources list, it will want to upgrade a lot of stuff.
Run "rpm -i <the apt rpm file you downloaded>".


then tried
Code: Select all
sudo apt-get --reinstall install libc6


as you suggested
it spit this out

Code: Select all
Reading Package Lists... Done
Building Dependancy Tree... Done
E: Couldn't find package libc6
flawed
 
Posts: 2
Joined: 15. July 2009 06:37

Re: XAMPP on Redhat

Postby aholverson » 29. April 2010 17:00

You are installing on RH9... you will need an older version of Apache (which is bundled with the xampp download). So download an older version of Xampp.

I downloaded 1.5.0, I haven't had time to try a newer version. Since you are using an older flavor of RH linux, you will need to use the older versions of the LAMP bundle. If you want the latest version, you'll have to update your RH9 with the latest packages that are used by Apache and the like.

Good luck!

Link to Sourceforge where older Xampp files are stored: http://sourceforge.net/projects/xampp/f ... P%20Linux/
aholverson
 
Posts: 1
Joined: 26. October 2006 05:24


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 6 guests