Problem setting up xampp ..

Problems with the Linux version of XAMPP, questions, comments, and anything related.

Problem setting up xampp ..

Postby shihao » 06. July 2009 07:52

Dear all,

I am struggle and wonder so long for the installation of xampp. After I download the xampp I unzip it using command
tar xvfz xampp-linux-1.7.tar.gz.
After that I move it into /opt directory. But when I try to
startover the xampp by using command: /opt/lampp/lampp start
Starting XAMPP for Linux 1.7...
XAMPP: Another web server daemon is already running.
XAMPP: Another MySQL daemon is already running.
XAMPP: Another FTP daemon is already running.
XAMPP for Linux started.

And when I try to browse http://127.0.0.1/xampp/
Warning: file_get_contents(lang.tmp) [function.file-get-contents]: failed to open stream: Permission denied in /opt/lampp/htdocs/xampp/index.php on line 2

Warning: Cannot modify header information - headers already sent by (output started at /opt/lampp/htdocs/xampp/index.php:2) in /opt/lampp/htdocs/xampp/index.php on line 4

Anybody who know how to solve please help!!
shihao
 
Posts: 7
Joined: 06. July 2009 07:44

Re: Problem setting up xampp ..

Postby shihao » 06. July 2009 08:57

OK, after I change the lampp/htdocs/xampp/lang directory and lang bmp file. I am able to browse at http://127.0.0.1/xampp/index.php already. Anyhow,

MySQL database DEACTIVATED
PHP ACTIVATED
Perl ACTIVATED
Common Gateway Interface (CGI) ACTIVATED
Server Side Includes (SSI) ACTIVATED

The mysql status still not ok. Furthermore, the phpmyadmin status is
#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured) .

Anyone who know the answer please help!!
shihao
 
Posts: 7
Joined: 06. July 2009 07:44

Re: Problem setting up xampp ..

Postby glitzi85 » 06. July 2009 09:08

Pleas install XAMPP as described in the Installation Manual: http://www.apachefriends.org/en/xampp-linux.html#377

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Problem setting up xampp ..

Postby shihao » 06. July 2009 09:53

Dear glitzi,

Thanks for your response. I am already finish step 4. The things is when my click phpmyadmin, the error message occurs as below:

MySQL said: Documentation #2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

Thanks and Regads
Shi Hao
shihao
 
Posts: 7
Joined: 06. July 2009 07:44

Re: Problem setting up xampp ..

Postby shihao » 07. July 2009 04:35

Dear glitzi,

I have redo the step, and it is works already. Maybe previously is the extraction problem, anyway thanks for helps.
shihao
 
Posts: 7
Joined: 06. July 2009 07:44

Re: Problem setting up xampp ..

Postby glitzi85 » 07. July 2009 15:51

shihao wrote:Maybe previously is the extraction problem, anyway thanks for helps.

Not maybe. That's the reason why you MUST install XAMPP for Linux as described in the Documentation.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Problem setting up xampp ..

Postby shihao » 08. July 2009 05:48

Dear all,

Another problem arise. When I restart my PC. My xampp cannot run already, the reason is another mysql is running...
So when I type ps -ef |grep mysql
root 4819 1 0 11:00 ? 00:00:00 /bin/sh /usr/bin/mysqld_safe
mysql 4861 4819 0 11:00 ? 00:00:02 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid --skip-external-locking --port=3306 --socket=/var/run/mysqld/mysqld.sock
root 4863 4819 0 11:00 ? 00:00:00 logger -p daemon.err -t mysqld_safe -i -t mysqld
tp 7392 7371 0 12:32 pts/0 00:00:00 grep mysql

The processes shows as above. I have to manually kill them one by one then only I restart the lampp
/opt/lampp/lampp restart
Stopping XAMPP for Linux 1.7...
XAMPP: Stopping Apache with SSL...
XAMPP: XAMPP-MySQL is not running.
XAMPP: Stopping ProFTPD...
XAMPP stopped.
Starting XAMPP for Linux 1.7...
XAMPP: Starting Apache with SSL (and PHP5)...
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

Hi guys. I know that this is a stupid way. Is there anyway to permanent stop the other mysql. So I don't need to kill and restart.
shihao
 
Posts: 7
Joined: 06. July 2009 07:44

Re: Problem setting up xampp ..

Postby Nobbie » 08. July 2009 12:03

Uninstall the other MySQL installation.
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Problem setting up xampp ..

Postby glitzi85 » 09. July 2009 12:50

Or remove the other MySQL installation from the init-Script (in case it is not removable by the package manager due to dependency)
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Problem setting up xampp ..

Postby shihao » 10. July 2009 03:05

Hi guys how to do that? I have forgot the path of the other mysql. So when I try to remove it, it shows
root@tp-desktop::/usr/bin# apt-get remove mysql-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package mysql-server is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 300 not upgraded.

When I try to find the directory
root@tp-desktop:/# whereis mysql
mysql: /usr/bin/mysql /etc/mysql /usr/share/mysql /opt/lampp/bin/mysql.server /opt/lampp/bin/mysql /usr/share/man/man1/mysql.1.gz

Dunno why got such many mysql, which one shall I uninstall and what command I shall use?
shihao
 
Posts: 7
Joined: 06. July 2009 07:44

Re: Problem setting up xampp ..

Postby Nobbie » 10. July 2009 10:27

>apt-get remove mysql-server

Maybe that's not the name of the package. You have to de-install the FULL mysql (not only the server), so you to find out the name of that package (maybe simply mysql, or mysql4 or mysql5 or mysql-common).

Which Linux are you running? There should be a grafical interface (aptitude or similar) which helps you to find out, which packages are installed.

Or simply follow the advice of "glitzi85" and decactivate the automatic start of mysql in /etc/init.d (i.e. in /etc/rcX.d, where X is the runlevel).
Nobbie
 
Posts: 8768
Joined: 09. March 2008 13:04

Re: Problem setting up xampp ..

Postby shihao » 13. July 2009 03:00

Dear Nobble,

I am using Ubuntu 8.10. Any idea how to find out ?
shihao
 
Posts: 7
Joined: 06. July 2009 07:44

Re: Problem setting up xampp ..

Postby glitzi85 » 13. July 2009 08:40

Run this command:
Code: Select all
dpkg -l > /tmp/packages.list

then post the complete content of the file /tmp/packages.list

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Problem setting up xampp ..

Postby lseeber » 10. August 2009 04:36

you can turn off your other myssql & apache server by doing the following
1. left click "system" on top toolbar.
2. go to "administration" then "services".
3. unlock
4. uncheck all "mysql" items and "web server apache2".
that will stop mysql & apache2 from starting, but won't stop XAMPP services from running.
then go to http://www.apachefriends.org/en/faq-xam ... l#sicherer to #3 to get it to start & stop when you shutdown & bring up your machine
lseeber
 
Posts: 1
Joined: 10. August 2009 04:17


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 3 guests