http://localhost not working

Problems with the Linux version of XAMPP, questions, comments, and anything related.

http://localhost not working

Postby nibiran » 30. June 2009 07:39

Hi,
I installed XAMPP as per the instructions in http://www.apachefriends.org/en/xampp-linux.html.

However when I tried to start XAMPP with the command /opt/lampp/lampp start, I get...
Starting XAMPP for Linux 1.7.1...
XAMPP: Another web server daemon is already running.
XAMPP: Starting MySQL...
XAMPP: Starting ProFTPD...
XAMPP for Linux started.

Note here that for Apache, it says that 'another web server daemon is already running'.

Because of this, when i type http://localhost it does not open the normal xampp page but gives the contents of /srv/www/htdocs/index.html.

How do i change this so that http://localhost will show me the normal xampp page?

With regards
Nibiran
nibiran
 
Posts: 1
Joined: 25. June 2009 03:32

Re: http://localhost not working

Postby Wiedmann » 30. June 2009 07:51

Because of this, when i type http://localhost it does not open the normal xampp page but gives the contents of /srv/www/htdocs/index.html.

How do i change this so that http://localhost will show me the normal xampp page?

Stop the webserver which is installed from your operating system.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Re: http://localhost not working

Postby threegremlins » 08. August 2009 04:56

Using yubun2 810, I'm having the same problem. You know I've been using Linux for years now but for the life of me I don't know how to turn the web server off either graphically or command line, never had problems with Linux so never had to before. Ya wanna run the process by me. I've managed to get the web server that is running to point to the right folder but I keep getting a 403-Forbidden message which I will have to ask at the CMS's forum.

never mind this didn't work after all
# A link for redirecting firefox to the folder you want to use
# http://ubuntuforums.org/showthread.php?t=223410

Learned a lot today, instructions to turn off my web server is.
sudo /etc/init.d/apache2 stop
this of course is for yubun2, another Linux platform will be different, you'll have to look it up or type in a terminal "man apache" for your instructions. So I bet your thinking why didn't I do that first, the answer is I didn't know because it worked so I didn't care. Do now though;)
But I should have read all the instructions before posting here, I can use the Xampp control panel, wow imagine that. Hey smart thinkin guys.
threegremlins
 
Posts: 1
Joined: 08. August 2009 04:32


Return to XAMPP for Linux

Who is online

Users browsing this forum: No registered users and 10 guests